Port-sandpoint archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: DS207 fails to auto boot (Bad Magic Number)

2014/1/3 Frank Wille <frank%phoenix.owl.de@localhost>
On Wed, 1 Jan 2014 22:42:04 +0100
Nick Østergaard <oe.nick%gmail.com@localhost> wrote:

> I had no success to netboot with the altboot with 8 descriptors provided
> by Julian.

Is there much traffic on your local network? Then it might be worth a
test to isolate the server and DS207 on a private network.


No there is not much traffic. It is a home network, consisting of my laptop (T410), the DS207, Cisco EPC3925 thingy, and an acient D-link DSE1008D switch to force 100Mbps-FDX. Another or two other wireless clients could be on, but not very active (just connected). I could try to turn them off completely. At least I would not consider that much, but it might still be too much, though as I understand it on the list, the home network was considered ok, just not a shared network in a big office.

So I tried to set my laptop up to provide the network [direct connection] (using archlinux and networkmanager), so actually ended op with something that netbooted. I but it works witht he normal altboot.bin and the altboot with 8 descriptors. Hence I am not sure if the 8 descriptors work any better. But I also noticed that this network is running 10Mbps-FDX, and I see one timeout. Is that expected?

Below is the procedure doumented, and only shown witht the modified altboot.bin -- but works with the normal one in this setup.

Press Ctrl+C to abort autoboot in 1 second
_MPC824X > setenv ipaddr                
_MPC824X > setenv serverip
_MPC824X > tftpload 1000000 altboot8desc.bin
ARP broadcast 1
ARP broadcast 2
TFTP from server; our IP address is
Filename 'altboot8desc.bin'.
Load address: 0x1000000
Loading: #################
Bytes transferred = 86272 (15100 hex)
_MPC824X > go 1000000 tftp:netbsd-INSTALL
## Starting application at 0x01000000 ...

>> NetBSD/sandpoint altboot, revision 1.10 (Tue Dec 31 12:17:02 GMT 2013)
>> Synology CS/DS/RS, cpu 265 MHz, bus 132 MHz, 64MB SDRAM
port 0 present
wd0: <ST31000528AS> DMA LBA LBA48 953869 MB
wd0a: ffs    (63)
wd0b: swap    (1953261135)
MAC address 00:11:32:01:65:56
Hit any key to enter interactive mode: 0
loading "netbsd-INSTALL" 5379064+134200=0x5424b8
entry=0x90000, ssym=0x5d2030, esym=0x5d24b8
Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005,
    2006, 2007, 2008, 2009, 2010, 2011, 2012
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.

NetBSD 6.1.2 (INSTALL)
Model: synology
total memory = 65536 KB
avail memory = 57804 KB
OpenPIC Version 1.2: Supports 1 CPUs and 26 interrupt sources.
mainbus0 (root)
cpu0 at mainbus0: 8245 (Revision 0.4), ID 0 (primary)
cpu0: HID0 0x90c000<DOZE,DPM,ICE,DCE>, powersave: 1
cpu0: 265.31 MHz
eumb0 at mainbus0
com0 at eumb0 unit 0: ns16550a, working fifo
com0: console
com0: interrupting at irq 40
ociic0 at eumb0
iic0 at ociic0: I2C bus
rs5c372rtc0 at iic0 addr 0x32: RICOH RS5C372[AB] Real-time Clock
satmgr0 at eumb0 unit 1: button manager (synology)
satmgr0: interrupting at irq 41
cfi at mainbus0 not configured
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0
pchb0: vendor 0x1057 product 0x0006 (rev. 0x14)
satalink0 at pci0 dev 13 function 0: Silicon Image SATALink 3512 (rev. 0x01)
satalink0: using irq 16 for native-PCI interrupt
atabus0 at satalink0 channel 0
atabus1 at satalink0 channel 1
ohci0 at pci0 dev 14 function 0: vendor 0x1033 product 0x0035 (rev. 0x43)
ohci0: interrupting at irq 17
ohci0: OHCI version 1.0
usb0 at ohci0: USB revision 1.0
ohci1 at pci0 dev 14 function 1: vendor 0x1033 product 0x0035 (rev. 0x43)
ohci1: interrupting at irq 17
ohci1: OHCI version 1.0
usb1 at ohci1: USB revision 1.0
ehci0 at pci0 dev 14 function 2: vendor 0x1033 product 0x00e0 (rev. 0x04)
ehci0: interrupting at irq 17
ehci0: companion controllers, 3 ports each: ohci0 ohci1
usb2 at ehci0: USB revision 2.0
skc0 at pci0 dev 15 function 0: irq 18
skc0: Marvell Yukon Lite Gigabit Ethernet rev. (0x9)
sk0 at skc0 port A: Ethernet address 00:11:32:01:65:56
makphy0 at sk0 phy 0: Marvell 88E1011 Gigabit PHY, rev. 5
makphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
vmmask 1c000000 schedmask 1c000000 highmask 7c000000
satalink0: port 0: device present, speed: 1.5Gb/s
wd0 at atabus0 drive 0
wd0: <ST31000528AS>
wd0: 931 GB, 1938021 cyl, 16 head, 63 sec, 512 bytes/sect x 1953525168 sectors
uhub0 at usb0: vendor 0x1033 OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1 at usb1: vendor 0x1033 OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2 at usb2: vendor 0x1033 EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
boot device: sk0
root on md0a dumps on md0b
root file system type: ffs
erase ^H, werase ^W, kill ^U, intr ^C, status ^T
Terminal type? [vt100]

Home | Main Index | Thread Index | Old Index