Port-sandpoint archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: DS207 fails to auto boot (Bad Magic Number)

On Mon, 30 Dec 2013 13:28:56 +0100
Nick Østergaard <oe.nick%gmail.com@localhost> wrote:

> Indeed it works now, though with a bit modified approach than described
> in the wiki. Basically the commands described in theis mail, and using the
> .img instead of .bin as you pointed out.

I'm glad you got it running!

> MAC address 00:11:32:03:52:af
> 100Mbps-FDX

The MAC address looks correct and the link-negotiation also worked.

Is it a Marvell 88E8001? What does the kernel print? There should
be something like this (from my DS-101g+):

skc0 at pci0 dev 15 function 0: irq 18
skc0: interrupt moderation is 0 us
skc0: Marvell Yukon Lite Gigabit Ethernet rev. (0x9)
sk0 at skc0 port A: Ethernet address 00:11:32:00:xx:xx
makphy0 at sk0 phy 0: Marvell 88E1011 Gigabit PHY, rev. 5
makphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 
1000baseT-FDX, auto

> timeout

The chip didn't receive a single ethernet frame. I have seen that before.

No idea what the reason might be. I'm also using a 100Mbps switch, and
the closest model I have for comparison is a CS-407e (also from 2007),
which shows no problem here.

This is especially strange because it worked from PPCBoot before,
so the chip was already correctly initialized. And when the NetBSD
kernel booted the NIC works again?

Frank Wille

Home | Main Index | Thread Index | Old Index