NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Booting from a USB disk

Here are the 3 use cases I tested:

1. The first disk, the one on which I have tried installboot,
had FreeBSD on it using ZFS and I had trouble reusing it. The
partition table was MBR.

2. The second disk had OpenBSD and installing NetBSD worked
perfectly. The partition table was also MBR.

3. The server was previously running FreeBSD using ZFS. The
R610 is  a UEFI-only system, so the partition table was GPT.
The size of the existing EFI partition was 200 MB.

My first installation attempt consisted in deleting the FreeBSD
partition but keeping the EFI one. I went through the whole
installation without any trouble, but the system refused to
reboot (can't remember the message).

However, after using the gpt command to destroy the GPT
table and create a new layout with a 128 MB EFI partition, the
installation works as well as before, but the system now boots

On 28/04/2020 06:35, Martin Husemann wrote:
On Mon, Apr 27, 2020 at 10:02:41PM +0200, Vincent DEFERT wrote:
The problem I had there is that NetBSD does not support EFI partition sizes
greater than 128 MB.
Can you explain this? What exactly goes wrong?


Home | Main Index | Thread Index | Old Index