NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Booting from a USB disk

I've tried to install NetBSD onto another disk and it worked, so I made further investigations on the disk having the issue. I turned out it had a remaining zfs_member signature somewhere, which I only saw after trying to recreate its partition table with fdisk under Linux. Once cleaned, the installation worked fine and the only manual operation needed is to check /etc/fstab, and fix it if needed.

I have also installed NetBSD on a server (Dell R610) previously running FreeBSD. The problem I had there is that NetBSD does not support EFI partition sizes greater than 128 MB. In this case also, I had to wipe the partition table, but I could do it with NetBSD's gpt(8).

A conclusion of this episode is that NetBSD works well, but is bad at wiping disks. ;)
Fortunately, this is only needed at installation. :)

On 27/04/2020 09:14, Martin Husemann wrote:
On Mon, Apr 27, 2020 at 08:53:16AM +0200, Vincent DEFERT wrote:
No, I haven't changed anything else and no modules are listed in /boot.cfg.

Is there any chance it worked due to a side-effect of not loading modules?
Yes, and I am currently out of ideas what went wrong.

I wonder if we should make the libsa version of "panic" wait for a key
press on the console, so you have a chance to fully read the message.


Home | Main Index | Thread Index | Old Index