NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Booting from a USB disk

Thank you for answering, Greg.

I've booted the installer from a USB key and installed NetBSD 9 on an USB disk known as /dev/sd0 (the key being /dev/sd1).
The machine is an Intel NUC6CAYH with 8 GB RAM and an up-to-date BIOS.

After successfully going the whole installation process (NetBSD installed on a single 235 GB partition + 8 GB swap), I reboot on my USB disk. I select choice 1 (boot multi-user) from the boot menu and the only message I have the time to read is "Heap full". The machine immediately continues with the only other available option, its internal disk with Void Linux.

If I reboot again and select choice 3 (drop to boot prompt) and type: 'boot hd0':, NetBSD boots correctly.

I have tried the UEFI installer, the other installer image, the standard kernel and the KASLR kernel, all give the same result.

I don't know what other details could help you to help me, feel free to ask more precise questions.

On 26/04/2020 14:46, Greg Troxel wrote:
Vincent DEFERT <> writes:

I've installed NetBSD on an external USB disk and made sure its
/etc/fstab was correct.
However, when I reboot on this disk, I have a "Heap full" error and
the machine boots on its internal disk.
It would help if you were much more precise about what you are doing to
boot and exactly what happens.  I can't tell if you are using the BIOS
to boot the disk, or some EFI thing, and how far it gets.

If I drop to the boot prompt and type "boot hd0:", NetBSD boots normally.
This is also unclear - a key point is if that boot loader was loaded
from the USB disk, or not.

My guess is that I need to set some additional option in some
configuration file.
With FreeBSD, I need to set vfs.mountroot.timeout="10" in
/boot/loader.conf, for instance.
Many things are possible, but far more information is needed to help

(Reply on list, not to me personally, as always.)

Home | Main Index | Thread Index | Old Index