NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Booting from a USB disk

No, I haven't changed anything else and no modules are listed in /boot.cfg.

Is there any chance it worked due to a side-effect of not loading modules?

I have previously tried: installboot /dev/rsd0a /usr/mdec/bootxx_ffsv2
(i.e. without the '-o modules') but it still had the 'Heap full' error.

On 27/04/2020 06:53, Martin Husemann wrote:
On Sun, Apr 26, 2020 at 10:23:03PM +0200, Vincent DEFERT wrote:
Here is the output of modstat in single user mode:

NAME                       CLASS    SOURCE   FLAG  REFS    SIZE REQUIRES
aac                        driver   builtin  -        1       - pci
So no modules loaded - and the installboot change was the only thing that
you changed?

Are there any modules listed in your /boot.cfg?

Something (and I have no clue what that could be) must have tried to load
modules, which then failed with the out of memory message. Now you have
inhibited module loading and it works.

However, nothing in a default install should cause modules to be loaded
this early (AFICT).


Home | Main Index | Thread Index | Old Index