NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Booting from a USB disk

from Vincent DEFERT <>:

> I've tried to install NetBSD onto another disk and it worked, so I made 
> further investigations on the disk having the issue.
> I turned out it had a remaining zfs_member signature somewhere, which I 
> only saw after trying to recreate its partition table with fdisk under 
> Linux.
> Once cleaned, the installation worked fine and the only manual operation 
> needed is to check /etc/fstab, and fix it if needed.

> I have also installed NetBSD on a server (Dell R610) previously running 
> FreeBSD.
> The problem I had there is that NetBSD does not support EFI partition 
> sizes greater than 128 MB.
> In this case also, I had to wipe the partition table, but I could do it 
> with NetBSD's gpt(8).

> A conclusion of this episode is that NetBSD works well, but is bad at 
> wiping disks. ;)
> Fortunately, this is only needed at installation. :)

This is the first time I see anything about NetBSD not booting by UEFI if the EFI system partition > 128 MB.

EFI system partition is activated before any OS is booted.

I read through the NetBSD wiki about UEFI booting, but where do I find something more comprehensive?


Home | Main Index | Thread Index | Old Index