NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: wireless and auto configuration

> I've used wpa_supplicant for 'known' wpa/psk (aes/tkip) encrypted 
> networks, it works well... but it needs manual configuration. 
> Auto-configuration script would be great!..

Thank you all for the many replies. I didn't realize that wpa_supplicant 
could be used for non-encrypted networks also.

I may give wpa_supplicant a try.

I don't know if it is related -- meaning I need some "wireless" daemon 
constantly managing my connections -- or due to my lack of knowledge, but 
my three NetBSD clients using wireless have problems:

1) ral0 -- connection drops -- so I ping my gateway once every 170 seconds 
"ping -n -i 170 -s 1" to keep it alive. I have had to do this 
with various NetBSD/amd64 versions for over 20 months now. Two different 
systems, same Linksys Wireless-G USB Network Adapter

2) rum0 -- connection drops frequently. Haven't tried my ping every 170 
seconds there. It is a Belkin Belkin 54g USB Network Adapter. ifconfig 
shows my inet address is gone and the status is "no network". I can't just 
run /etc/rc.d/network restart since when dhclient reassigns my IP, my 
default route is not fixed and so networking still doesn't work. So I also 
restart dhclient. This is on NetBSD/amd64 -current.

3) iwi0 -- connection temporarily freezes on NetBSD/i386 4.0 and -current 
from over a month ago. My ssh connection to the system or web browsing on 
the system may temporarily be down for a minute or so. Can't ping it. 
pinging from it seems to wake it back up in about five to ten seconds and 
then I can ping to it again and my existing SSH connections works again. 
This happens many times a day.

As for auto-configuration for wpa_supplicant, what type of behaviour is 
desired? Parse "wiconfig <interface> -D" output for best signal? Any 

For some reason, my current "wiconfig ral0 -D" output shows three access 
points with identical Quality/Signal/Noise [signal] and [dbm]. The third 
one is less than 20 feet way down a hall. The other two I have no idea 
where they are. At the closest that must be over 50 feet away in a 
different building.

Hmmm.. Running "wiconfig ral0 -D" seems to have disabled my networking.
I tried to reconfigure it several times, but no luck. So I unplugged the 
USB adapter and plugged it back in and it worked again.

Also frequently when I run "wiconfig ral0 -D" or on another system 
"wiconfig rum0 -D" I receive an ioctl error:
scanning ...wiconfig: ioctl: No such file or directory

And sometimes I get (after about five seconds):
scanning .............wiconfig: ioctl: Operation now in progress

Home | Main Index | Thread Index | Old Index