Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: bootparam_prot.h: No such file or diretory

On 17/01/2008, Sarton O'Brien <> wrote:
> Kimi wrote:
> > On 16/01/2008, Sarton O'Brien <> wrote:
> >
> >>
> >> Could it be there is a required set missing? Admittedly I never use the
> >> 'build' target but searching for the missing file listed yields:
> >> /usr/include/rpcsvc/bootparam_prot.h
> >
> > "build" is part of "distribution" which is part of "release". being
> > that it's an include I decided to run make includes under /usr/src
> > after making sure "bootparam_prot.h" actually exsisted under
> > /usr/include, but maybe it was botched so did a make includes.
> >
> Have you ever tried without NFS or is NFS required?

well, I have tried /usr/obj without being mounted via NFS.

> I have had issues in the past when compiling from sets, though nothing
> this obscure. I've never had an issue with an updated /synced cvs repo,
> outside of usual development changes taking place.
> All my sources reside on NFS via tcp as I seem to remember I had some
> real flakiness using UDP, especially when compiling and it only seemed
> to effect the client.

I have been meaning to change to TCP, performance to me isn't
everything where as stability is. same reason I use *BSD.

> Other than the clock skew and using a local filesystem, a cvs sync with
> anoncvs to ensure the integrity of the source files is about all I can
> suggest ... but seeing as you've tried so many sets and synced with
> cvsup, it's hard to believe that that would be the case.

At the moment I am compiling libcrypto, I can not remember if
librpcsvc is before or after.

so seems to be a clock skew issue, time will tell.

plus it's taking longer at the moment as I'm doing this under vmware
workstation, the actual computer is having some tests run with

> I can't wait to find out how you actually fix this :)

me too

> Sarton


Home | Main Index | Thread Index | Old Index