Port-amiga archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Re: Re: AmigaOS 3.2 kickstart ROM crashing on NetBSD partitions (Was NetBSD/amiga sysinst)

On Sat, 25 Mar 2023 at 19:10, Karoly Balogh <charlie%scenergy.dfmk.hu@localhost> wrote:
> Hi,
> On Sat, 25 Mar 2023, David Brownlee wrote:
> > > The patch works like this: if opening "console.device" fails, it tries to
> > > initialize the "console.device" ROM module using FindResident and
> > > InitResident, and then open the device again. For older Kickstarts, the
> > > code is practically unchanged, because there the first opening already
> > > works. For newer Kickstarts, this works around the initialization issue.
> >
> > Nice work!
> >
> > I can definitely get this committed to the NetBSD tree, and pulled up
> > into earlier branches.
> Thanks.
> > As you have everything to hand are you able to confirm it works fine
> > on 3.1 (and probably 2.05) - or throw up a quick hdf for others to
> > look at?
> I tested it with 3.1 (v40.68) as well, it works. Personally, I do not use
> these newschool Kickstarts at all. I admit, I had to pirate^Wborrow one to
> be able to look at the issue, just out of plain curiosity. :P
> As I wrote the code path doesn't change for older Kickstarts (where
> opening console.device "always" succeeds), I do not see why it could cause
> a compatibility issue.

I agree it absolutely should not affect 3.1 as the code path only
changes based on a test which only triggers in 3.2, but there is
always the occasional "code moved around some now
something-something-something broke because some code omitted setting
something and it Just Worked before, but now fails", kernels and
boot-blocks a speciality :)

> But of course, all tests are welcomed, so be my guest:
> http://charlie.amigaspirit.hu/temp/private/netbsd-bb-fixed.hdf.xz
> Note: I did not test this HDF image any further than if it loads the
> bootblock successfully. Probably not, but it is what came out as
> "miniroot.fs" from some current NetBSD source I pulled from GitHub. But
> this behavior is regardless of Kickstart version and my patch. I did not
> investigate that part at all.

I tested in fs-uae with 2.05, 3.1 and 3.2, and the new boot blocks
worked for all, and the old failed in 3.2 (as expected).

I think that's good enough to say "Ship it" :)

Just committed it to NetBSD -HEAD. Let me get a release build, and
test pullups to netbsd-10 and netbsd-9. I would submit a pullup for
netbsd-8, but the bootblocks from -8 are also missing the change to
boot from a ffsv2 root filesystem, so we'll stick with -10 and -9.

Thanks again

Looks like things continue to get a little better for NetBSD/amiga :)


Home | Main Index | Thread Index | Old Index