NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Unusable Realtek NIC after upgrading to NetBSD 9

On set 17  8:55, Vincent DEFERT wrote:
> You could try opening the firmware update's executable as an archive
> (they are often SFX - self-extracting ZIP archives),
> extract its contents to a FAT-formatted USB pen drive,
> reboot the laptop with the pen drive attached
> and enter the BIOS firmware flash utility (often the F7 key).

This is a good advice, which can be useful for similar cases. As regards
my laptop, the file is

(yes, the Compaq BIOS update is distributed by HP, it sounded weird to
me, too).
I tried to extract it with GUI `Ark' on Linux, with CLI `unrar' and by
executing the file itself, after renaming it as `sfx', as suggested

It didn't work, so maybe it's a different format.

> If you found a firmware update from 2014, your laptop may not be
> so old it can't update from a USB stick. :)

No, in fact IIRC it should also be able to boot from a USB stick (maybe
just for one of the external connectors, not all of them).

If the NIC never worked, a BIOS update could be meaningful. But this is
a different case. If with 8.1 the NIC worked, it should also work with

Of course, a driver design requires a massive work I can't imagine and I
understand that simple needs of the user are not that much simple from
the developer's perspective.


Home | Main Index | Thread Index | Old Index