NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Unusable Realtek NIC after upgrading to NetBSD 9

Using NetBSD 8.1 in a laptop, both its Ethernet and WiFi NICs worked.
Then, I made a NetBSD 9 (formal release) fresh install and the
Ethernet NIC is almost unusable.

Here, the relevant dmesg part:

[     1.055234] re0 at pci3 dev 0 function 0: RealTek
8100E/8101E/8102E/8102EL PCIe 10/100BaseTX (rev. 0x05)
[     1.055234] re0: interrupting at msix3 vec 0
[     1.055234] re0: Ethernet address 28:92:4a:29:53:5a
[     1.055234] re0: using 256 tx descriptors
[     1.055234] rlphy0 at re0 phy 7: RTL8201E 10/100 media interface,
rev. 2
[     1.055234] rlphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX,

The card is detected and configured by the system, but it is extremely
slow: a Google ping may take up to 10 seconds (yes, 10000 ms). An ssh
connection is extremely slow, making it unusable.

It seems that, if I use the card, the dmesg gets populated by this
repeated message:

[ 20690.751223] re0: watchdog timeout
[ 20695.773292] re0: watchdog timeout
[ 20706.809817] re0: watchdog timeout
[ 20720.853570] re0: watchdog timeout
[ 20730.887686] re0: watchdog timeout

I also tried to boot disabling rlphy(4) (`userconf disable rlphy' from
the boot prompt), and ukphy(4) is used instead, but nothing changed.
The same happens with netbsd-9 (stable).
This problem did not appear with NetBSD 8.1, so it is a regression.
Is there anything I can do?


From `ifconfig -a' (note that the Ethernet cable is currently
disconnected, because I can't use the card):

re0: flags=0x8802<BROADCAST,SIMPLEX,MULTICAST> mtu 1500

        address: 28:92:4a:29:53:5a
        media: Ethernet autoselect (none)
        status: no carrier
        inet broadcast flags 0x4<DETACHED>
        inet6 fe80::2a92:4aff:fe29:535a%re0/64 flags 0x8<DETACHED>
scopeid 0x1


Note that this is not the same issue as the previous thread:


which has been solved.

Home | Main Index | Thread Index | Old Index