NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: inconsistent pkgdb during upgrade


Pongthep Kulkrisada wrote:
pkg_info dies with the same error:
pkg_info: cannot read meta data file +COMMENT of package suse_x11-11.3:
No such file or directory
grid$ sudo pkg_admin rebuild
pkg_admin: suse_x11-11.3: can't open `+CONTENTS'

how can I fix that?


Can you check existence of /var/db/pkg/suse_x11-11.3/?
Files like +COMMENT or +CONTENTS are placed here.
These files are used by pkg_info.
If some are missing, pkg_info will fail.
It doesn't... it contains only a core file because linux emulation never worked properly for me (never got help to make it work though)

grid# ls /var/db/pkg/suse_x11-11.3/

BTW, I believe that you have already tried simply ``make deinstall''.

well, the problem is that the directory doesn't contain makefile anymore. I suppose it got removed upstream or something like that?
grid# cd /usr/pkgsrc/emulators/suse113_x11/
grid# ls
CVS  work

"cvs update" doesn't retrieve the makefile.

I suppose that the suse_x11-11.3 package directory is "spurious" because of the core file, so it could not have been deleted during uninstall. I thus removed it. I applied this cure also for other suse_* packages, which all contained only core files.

finally pkg_info runs again. I will resume the update I was performing on xulrunner and hope that it will work fine now :) Crossing fingers!

I will then update to the newer packages and check linux compatibility again.


Home | Main Index | Thread Index | Old Index