NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Web browser: stuck with Opera-9.62

For several years, since at least NetBSD-4.something, I have had
seamonkey and later firefox in quite well working condition. A native
build, including native Java, and for the last two years or so, even
with working Flash using pluginwrapper.

However, this seems to become more and more fragile. When I tried to
rebuild my 5.1 system, sound stopped working in Flash. My latest
nearly-working system was a ThinkPad R50e with NetBSD 5.1 and Firefox
3.6. I can't remember versions of Java, Flash or pluginwrapper, alas
the machine failed due to old age a few days ago. Java worked for some
things, but since I switched from a self-built native JDK to OpenJDK,
I had some problems with signed applets, rendering for example my
netbanking useless. Also, FF 3.6 leaked memory excessively, to the
point that I had to restart it twice a day.

Right now I am using a machine with 5.99.58 and versions of everything
from pkgsrc-current, as it was on 9. december 2011. Flash is
unfortunately not working, and Java I have not really tested yet.
openjdk7- Open-source implementation of the Java
Platform, Standard Edition
xulrunner-8.0       XML User Interface Language runtime environment
nspluginwrapper-1.2.2nb10 Use Netscape compatible plugins from other platforms
libflashsupport-1.1 Additional Interface Support for Linux Flash Player
adobe-flash-plugin- Adobe Flash Player Browser plugin

As this is currently my only machine, I will have to live with this
setup for a while. If my laptop hadn't failed, I would have tried
building a 5.1 system again, to see if I could get Firefox and Flash
working again.

It seems to me as if there really isn't that much preventing native
FF+pluginwrapper+Flash+OpenJDK from working quite well, alas I don't
possess the skills to find out what is. Back in december David
Brownlee posted something about FF not building with pulseaudio for
example, I replied with a similar experience, but nothing much came of


Home | Main Index | Thread Index | Old Index