Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: help with bluetooth

On Wed, Jan 02, 2008 at 10:09:28AM +0000, Iain Hibbert wrote:
> On Wed, 2 Jan 2008, Dieter Baron wrote:
> > On Tue, Jan 01, 2008 at 10:19:06PM +0000, Iain Hibbert wrote:
> > > 1. "btconfig ubt0 ptype 0x0018" - I don't know why but some devices seem
> > >     to require this or something like. It limits the air packets to the
> > >     bare minimum that its mandatory to support rather than what the device
> > >     claims to support.
> >
> >   Yes, thank you, that helped.  I can now send an sdpquery, create a
> > DUN connection, get files via obexftp and send files via obexapp.
> Cool. can you show me output of 'btconfig -vvvv' please?  The kernel code
> attempts to DTRT by reading the features and constructing the best value
> but maybe the features lie (it has been known though I haven't seen a
> device that does that). I'm not sure but using this value may cause slower
> data transfer in a congested bluetooth area since it reduces the options
> available.

  # btconfig -vvvv
btconfig: HCI cmd (0c44) failed (status 1)
ubt0: bdaddr 00:0f:b3:99:e0:ee flags 0x3<UP,RUNNING>
        num_cmd = 1
        num_acl = 8, acl_mtu = 192
        num_sco = 8, sco_mtu = 64
        class: [0x12010c] Laptop Computer <Networking> <Object
        name: "legba"
        voice: [0x0060]
                Input Coding: Linear PCM [16-bit, pos 0], 2's
                Air Coding: CVSD
        pin: variable
        options: iscan pscan -auth -encrypt switch -hold -sniff -park

> > > 5. You could try for incoming connections by setting up comms/obexapp and
> > >    attempt to send something from the phone to the computer.
> >
> >   This, however, I cannot get to work.  I tried
> >
> > # obexapp -ds -C 10
> >
> > but the phone could not find any device when trying to send a note.
> > Any hints on this one?  Or how to get notes via obexftp?  As far as I
> > can tell, obexftp can only access items located in the phone's Gallary
> > (images, sounds; but not notes or contacs).
> The obexapp manpage has some information about extracting contacts, they
> don't show up in the directory scans and I'm not sure which sync programs
> work and how well as I've never investigated that (please let me know if
> you get something working, we could add it to the guide)

  Ah, I missed that.  From a quick test, it looks like my phone only
supports OBEX level 1 (putting objects):

# obexapp -c -a tim -C 10 -n get telecom/pb.vcf
Could not connect to the remote OBEX server. Response: Unknown
response (0x4c). Service: None

> Notes are just plain text files but the filename doesn't always come
> through. If I send a note from a nokia phone to my laptop I just get
> Nokia.txt appearing

  For me too.  I guess I'll have to add an option to obexapp so it
doesn't overwrite files with the same name.

> - for the other direction, the phone keeps a list of
> notes someplace private. On a windows mobile phone you are just in the
> 'Bluetooth Share' folder and see whatever is there and I think filenames
> are remembered.
> in my /etc/rc.conf I use
> obexapp=YES
> obexapp_username="plunky"
> obexapp_pathname="/home/plunky/obex"
> obexapp_channel="10"
> and additionally you probably need to set the <Object Transfer> bit
> 0x100000 in the class of device setting as some Nokia phones filter the
> inquiry results before displaying the list. I have:
>       class: [0x12010c] Laptop Computer <Networking> <Object Transfer>
> Oh, and of course you must be discoverable (enable inquiry scan)

  Thanks, that worked.

  I'll write this up so we can enhance the OBEX sub-section in the
guide -- the link to the package is not very helpful in case of

  Thanks for the help.


Home | Main Index | Thread Index | Old Index