tech-userlevel archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Making powerd=YES default

On Mon, 01 Aug 2011 01:02:16 +0200
Jean-Yves Migeon <> wrote:

> > Not everyone uses etcupdate.
> > Will an official update via sysinst now have the correct values in rc.conf?
> Good point; nope. That's something you can only do via postinstall(8).

Sorry for replying to such an old thread;

Since I upgrade from source (and NFS-mounted tree for other hosts using
the install target), I have no experience with the sysinst
upgrade option.

However, I always assumed that after extracting the sets it allowed to
run etcupdate and postinstall scripts.

If it doesn't, how hard would it be to make it do so?  I don't think
that an upgrade is complete without being able to use those scripts,
personally.  And of course, I don't think that it should run those
automatically, but each on user request (with "check" and "fix" options
for postinstall).

Perhaps that a more tricky part would be where "fix" will not
automatically fix a problem (i.e. missing user/groups), where a
powerful enough interface is required to fix such, however.
Perhaps that with the sysinst+lua revamp this could become part of
future possibilities...


Home | Main Index | Thread Index | Old Index