Port-alpha archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Netbooting a machine w/ a disk

On Mon, Mar 2, 2009 at 4:58 PM, David Brownlee <abs%netbsd.org@localhost> wrote:
> On Mon, 2 Mar 2009, Dustin Marquess wrote:
>>>        If you set the raid to autoconfigure as a root filesystem
>>>        (raidctl raid0 -A root) then a kernel will automatically
>>>        use it as the root filesystem, at least for a standard
>>>        kernel without a hardcoded root device. I've not tried it
>>>        with a kernel which had hardcoded the root device - let us
>>>        know what happens :)
>> Honestly I went ahead and rebuilt a kernel hardcoded to raid0a to be
>> on the safe side, and it worked great.  I still have the old one
>> backed up however that I could try if you really want me to, but
>> honestly I'm slightly scared :).
>        Heh, give is a span next time you need to reboot for any
>        other reason maybe.

Went ahead and gave it a shot.  Didn't work (Yes, I know running mixed
disks isn't optimal :) ):

sd0 at scsibus1 target 0 lun 0: <SEAGATE, ST318406LC, 010A> disk fixed
sd0: 17501 MB, 26302 cyl, 2 head, 681 sec, 512 bytes/sect x 35843670 sectors
sd0: sync (12.50ns offset 63), 16-bit (160.000MB/s) transfers, tagged queueing
sd1 at scsibus1 target 1 lun 0: <FUJITSU, MAS3184NP, 0104> disk fixed
sd1: 17524 MB, 27206 cyl, 2 head, 659 sec, 512 bytes/sect x 35890512 sectors
sd1: sync (6.25ns offset 127), 16-bit (320.000MB/s) transfers, tagged queueing
Kernelized RAIDframe activated
raid0: RAID Level 1
raid0: Components: /dev/sd0a /dev/sd1a
raid0: Total Sectors: 35839872 (17499 MB)
root on sd0a dumps on sd0b
vfs_mountroot: can't open root device
cannot mount root, error = 16
root device (default md0a):


Home | Main Index | Thread Index | Old Index