Port-alpha archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Netbooting a machine w/ a disk

On Mon, Mar 2, 2009 at 3:22 AM, David Brownlee <abs%netbsd.org@localhost> wrote:
> On Sat, 28 Feb 2009, Dustin Marquess wrote:
>> Awesome.  Out of shear luck I did just that last night and started the
>> kernel compile before I went to bed.  Thanks for the confirmation :).
>> If I want to use RAIDframe in a RAID-1 setup, do I change the root
>> setting from sd0 to raid0?
>        If you set the raid to autoconfigure as a root filesystem
>        (raidctl raid0 -A root) then a kernel will automatically
>        use it as the root filesystem, at least for a standard
>        kernel without a hardcoded root device. I've not tried it
>        with a kernel which had hardcoded the root device - let us
>        know what happens :)

Honestly I went ahead and rebuilt a kernel hardcoded to raid0a to be
on the safe side, and it worked great.  I still have the old one
backed up however that I could try if you really want me to, but
honestly I'm slightly scared :).

Only weird thing that I've noticed is that once I'm in NetBSD, if I
reboot/halt back to SRM and try to boot again, BOOTP just sits there
and times out, almost like network connectivity isn't working.  But if
I 'init', it works again.  Very strange..

Thanks for all of the help!


Home | Main Index | Thread Index | Old Index