Port-alpha archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Netbooting a machine w/ a disk

On Mon, 2 Mar 2009, Dustin Marquess wrote:

       If you set the raid to autoconfigure as a root filesystem
       (raidctl raid0 -A root) then a kernel will automatically
       use it as the root filesystem, at least for a standard
       kernel without a hardcoded root device. I've not tried it
       with a kernel which had hardcoded the root device - let us
       know what happens :)

Honestly I went ahead and rebuilt a kernel hardcoded to raid0a to be
on the safe side, and it worked great.  I still have the old one
backed up however that I could try if you really want me to, but
honestly I'm slightly scared :).

        Heh, give is a span next time you need to reboot for any
        other reason maybe.

Only weird thing that I've noticed is that once I'm in NetBSD, if I
reboot/halt back to SRM and try to boot again, BOOTP just sits there
and times out, almost like network connectivity isn't working.  But if
I 'init', it works again.  Very strange..

        It sounds like NetBSD is leaving the network interface in a
        state that SRM doesn't quite handle. Out of curiosity what
        happens if you delete the network interface and shutdown
        the interface before halting - 'ifconfig tlp0 delete'
        'ifconfig tlp down' (replace tlp0 with network interface
        of choice :)

                David/absolute       -- www.NetBSD.org: No hype required --

Home | Main Index | Thread Index | Old Index