pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: long-broken packages (some are removal candidates)

On Mon, Apr 02, 2012 at 05:02:37PM +0900, OBATA Akio wrote:
 > >Inspecting the failed work dir, I found this:
 > >
 > >ASDocGen ERROR: Cannot open file 
 > >/home/pkgbulk/c/obj/wm/afterstep/work/.home/.afterstep/non-configurable/workspace_state
 > > for writing!
 > > Please check permissions or contact your sysadmin !
 > >
 > >in AfterStep-2.1.2/src/ASDocGen/, which is apparently where it
 > >hides the record of what it's doing when generating roff docs.
 > >
 > >There's also a log.html, which is empty.
 > >
 > >I'm guessing the problem is that it's trying to use $HOME, or that
 > >it's trying to use the homedir from getpwuid(), or both. The latter is
 > >not writeable by the bulk build user in my setup, and probably also in
 > >Joerg's.
 > Former is not used (I've confirmed with chmod -w ${HOME}), and later is 
 > writable.
 >  Why FAKEHOME is not writable with builk build (it's in ${WRKDIR})?
 > Then I tried to create FAKEHOME without write permission,
 > but still built&installed fine.

Well... $HOME points to the fake home. As far as I know we don't do
anything to intercept getpwuid() and lie about the result.

The reason it can't create the file it wants is that .home/.afterstep
doesn't exist.

I was theorizing that maybe it tried to create ~/.afterstep using the
directory from the password file, and failed to notice or report that
it couldn't do so. Or something like that.

Anyway, it's pretty clear now that the problem is that ASDocGen is
doing something wrong in my environment. Not so clear what yet...

David A. Holland

Home | Main Index | Thread Index | Old Index