pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Anyone have firefox working on i386?

On my i386 system running 5.1_STABLE, I have both "firefox36-3.6.22"
and "firefox-6.0.2" installed using "pkg_add" (on 2011-11-19), based
on this in /etc/pkg_install.conf:

My X server is "/usr/X11R7/bin/X", the one that comes with the O/S.

"firefox36" works.  "firefox" never worked; it fails to open a window,
and says this on stdout:

  Failed to initialize GEM.  Falling back to classic.
  failed to create drawable

I had the same problem with 2011Q2, which I reported last August
to this list ("firefox won't start, 2011Q2") - actually at the time
I had not realized that "firefox" has become firefox 4, which didn't
work for me, and explicitly getting and using firefox36 solved my
problem in the short term.

Anyway, at this point I really want to upgrade to a more recent
firefox to take advantage of some plug-ins that no longer support
what is essentially an obsolete version.  But I have no idea where
to start debugging this; my system is quite "vanilla" for most
purposes, and I installed a precompiled binary.  "pkg_add" should
have pulled in any dependencies.  "make run-depends-list" in
/usr/pkgsrc/www/firefox doesn't show anything as missing.

Is anyone out there actually successfully using firefox (6)
on an i386?  If so, how did you install it?

Ms. Anne Bennett, as a private citizen:
Also reachable more officially at work:

Home | Main Index | Thread Index | Old Index