pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: sysutils/amanda not working - resolved


Thanks for the PR/patch.  I've taken ownership of the PR, and will
commit something based on that.  We have a standard option inet6, on by
default, so I'll use that, but it will do the same thing.

  2. Previous versions of amanda provided an appropriate default value
     for tapedev (ie, /dev/nrst0), but the new version does not.  So I
     had to add that to my amanda.conf file.  The new default value of
     "null" is documented in the amanda.conf(5) man page, so I did not
     file a PR for this.  But it sure would be nice if the update
     process would tell you about this change in behaviour.  :)

True, but that's what upstream NEWS is for, and when dealing with pkgsrc
I don't try to accomodate upstream lack of perfection too hard - it's
too much work.

  3. Previous versions of amanda defaulted to /usr/pkg/etc/amanda for
     the amanda.conf's indexdir parameter.  The new version defaults to
     /usr/adm/amanda which doesn't exist on NetBSD.  I've filed PR
     pkg/38958 for this, and for now have added indexdir parameter to
     my amanda.conf file.

I took the PR, but I think things belong in /usr/pkg/var/amanda since
etc is for config.  ok with you?

  4. The new version maintains a new file /etc/amandates but does not
     create it when it doesn't exist.  This file needs to be manually
     created on all amanda clients.  I'm not sure if this should be
     handled automatically by the build process, so I did not file a
     PR for this.

     As a side note, I've noticed that even after a successful backup
     run, nothing has been entered into the /etc/amandates file that
     I created.  But the file must exist in order for the sendsize
     (and presumably sendbackup) programs to work properly.

Upstream bug, perhaps.  Should be in VARBASE/amanda, but that may be

Home | Main Index | Thread Index | Old Index