pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: confusion regarding .include vs DEPENDS

Larson, Timothy E. wrote:
When reading chapter 10 of the pkgsrc doco, I am confused about including
the buildlink3 file vs having DEPENDS in the makefile.  The doco seems to
indicate a preference to using buildlink3 files, but how do you specify a
minimum version for the dependency that way?  I don't want to force
dependencies to be updated when it's not necessary.

You want to include a dependency's files *only* if the package links against libraries provided by the dependency. Otherwise, use DEPENDS.

See Juan's reply for how to set the version for a file.


        -- Johnny C. Lam

Home | Main Index | Thread Index | Old Index