NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD on Linode problems

On Tue, 9 Oct 2012, Eric Schnoebelen wrote:
Michael Parson writes:
- I'm trying to get NetBSD installed on a Linode (Xen) VM following the
- instructions on this Wiki page:
- Networking works under the Finnix image, I am able to to use wget to
- download the files needed, but when I boot the NetBSD installer images,
- I am unable to get networking to work under NetBSD. I have tried both
- 32&64 bit kernels (under 32 & 64bit pv_grub). If I try and let it get
- networking via DHCP, it doesn't get a response, if I use hard-coded
- values, no traffic gets passed.

What is the Dom0 OS and version?  Some distro's of Linux
(Debian) changed the network backends supported in Xen.

I don't know the OS or version of the Dom0.  I'm suspecting some version
of Linux, given that this is their focus, but they don't seem to make
that info easy to find.  Is there anything I can run in a DomU installed
OS to get that info?  I can install Linux temporarily if that would

NetBSD 5.1-STABLE supports the newer Xen backend, while
5.1-RELEASE and before do not.. :(

So, what is the version of NetBSD you're attempting to use?

I'm trying to install 5.1.2, I've tried both i386 and amd64.  The
installer boots, I just can't get networking working.

FYI: I've had good luck with NetBSD Xen hosting at Panix and
GPLHost (Singapore)

Nice, Panix actaully lists NetBSD as a supported OS, I might have to
give them a shot, thanks for the pointer.

(sometimes I wonder if I should establish a NetBSD Dom0 based
Xen hosting service.. I know of no one providing such a service.)

Michael Parson
Austin, TX

Home | Main Index | Thread Index | Old Index