NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Some progress in support for HP USB printer/scanners

On Sat, Sep 22, 2012 at 03:36:50PM +0530, Mayuresh wrote:
> Have always struggled to get HP USB all-in-one printer (F380) on NetBSD,
> though hplip and sane are known to support it and they work on Linux.
> Some of the past mails on this are in this thread:
> Recently I tried it on 6.0 rc1. Do not know whether changes from 5.1 to
> 6.0 in NetBSD or any developments in hplip have helped, though now the
> device is getting detected fine (with ugen enabled in kernel, which was
> tried before also).

There is one more significant observation to report.

I identified the printer device with trial and error to be /dev/ugen0.03

If I use foomatic-rip on NetBSD and redirect its output to printer device
it does not print.

However if I use same foomatic-rip command on Linux and save its output in
a file and later redirect this saved file to above device on NetBSD it
_does_ print on NetBSD.

Also tried using same ppd file that was in use on Linux with NetBSD's
foomatic-rip though that didn't work.

Anyway, this was my first success whatsoever to print using my HP USB
printer on NetBSD.

Now a few points where I seek help / comments:

1. I just have to figure out the difference in the behavior of
foomatic-rip on Linux and NetBSD and I'll be done. Will check the versions
first, though I don't think they'll be too different.

2. I see the printer is found sometimes at /dev/ugen0.03 and some other
times and /dev/ugen1.03 (after reboot). What is the reason it changes
across sessions or is that to be expected?

3. After getting above insights I find cups machinery to be overkill for
simple personal use desktop printing (with due regards for cups' utility
for heavier jobs).

Any comments?


Home | Main Index | Thread Index | Old Index