NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Some progress in support for HP USB printer/scanners

> Some of the past mails on this are in this thread:

> Recently I tried it on 6.0 rc1. Do not know whether changes from 5.1 to
> 6.0 in NetBSD or any developments in hplip have helped, though now the
> device is getting detected fine (with ugen enabled in kernel, which was
> tried before also).

> However the printer is still far from functioning. Seek advice on
> following attempts to make printer and scanner work:

> Please bear with the length of the mail and do suggest if there is
> something I could try:

> 1. Printer with cups:

> The cups web ui shows printer state as : "/usr/pkg/libexec/cups/backend/hp
> failed"

> The said file exists and exits with 0 status if tried manually. No idea
> how to analyze this further. The error logs showed nothing that sounded
> like any hint.

> 2. Printer with lpd:

> Tried setting up as per NetBSD user guide. Not sure what device to set as
> print device. There is a bunch of them as /dev/ugen0.* and /dev/ugen1.*

> Trying to redirect text to /dev/ugen* devices (one by one) did not seem to
> bother the printer.

> 3. Printer with hp-print (from hplip)

> Going to try this, though it seems to have qt dependency. Taking long time
> to build.

> 3. Scanner with sane-backend

> sane-find-scanner detects the scanner now, though scanimage doesn't. Also
> tried as root, so permissions is not an issue. The hpaio backend is known
> to support this scanner and the same is mentioned in dlls.conf file as per
> installation instructions.

> 4. Scanner with hp-scan (hplip tool)

> This works! But scanning is terribly slow. Accidentally launched hp-scan
> again before previous one fully finishing. This resulted in hanging of
> NetBSD and had to be powered off.

> 5. Passing the device to qemu and making Linux deal with printer and
> scanner:

> Tried passing options like -usb -usbdev host:0x03f0:0x5511 to qemu guest
> Arch Linux, though lsusb on the guest does not show this device. Not sure
> what is the right way to pass the device.

> I am using NetBSD 6.0 RC1 on i386 and current pkgsrc.

> Mayuresh.

Does the printer work with Arch Linux on its own as opposed to qemu guest?

Could you build wine from pkgsrc and try the MS-Windows setup?  I thought of
doing that, at least for FreeBSD and possibly Linux.

What interfaces does your printer have?  Ethernet, wireless as well as USB?

My printer has USB and Ethernet, but no wireless.

Am I better off working with NetBSD 6.0 (pre)release or HEAD?

I've been cross-compiling NetBSD 5.1_STABLE for i386 and amd64 from 
FreeBSD 9.0-STABLE using, then building modular-xorg from pkgsrc, 
intend to go on to NetBSD releng 6 and HEAD.  I installed NetBSD 5.1_STABLE 
on USB sticks, intend to do that with releng 6 using GPT on the USB sticks,
then would install HEAD to two partitions (i386 and amd64) on a USB 3.0 hard
drive (Western Digital My Book Essential, 3 TB).  Since NetBSD lacks 
USB 3.0 support (xhci), I would need to use a USB 2.0 port.  This USB hard
drive does not work on a USB 2.0 port directly connected to the motherboard 
but works on a port on a USB 2.0 bracket connected to USB 2.0 headers on the
motherboard.  But I believe I could cross-compile and install from FreeBSD
using USB 3.0 since FreeBSD, at least the newer versions, supports xhci.

FreeBSD ports' latest version of hplip is 3.12.2 while pkgsrc has hplip 3.12.6.
I think upstream is up to 3.12.9 on hplip.


Home | Main Index | Thread Index | Old Index