NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: number of seconds since the epoch

On 9 Dec 2010 at 2:26, Taylor R Campbell wrote:

>    Date: 08 Dec 2010 11:21:41 -0500
>    From: Daniel Hagerty <>
>    Robert Elz <kre%munnari.OZ.AU@localhost> writes:
>    > Clearly you're looking for a count of seconds including
>    > leap seconds, right?   That's the magic 24 in your message.
>    > That is you're not interested in the elastic seconds that
>    > posix defines, for which there are always exactly 86400 in a day.
> Exactly.  I'd like to do this without customizing my installation of
> the operating system from source, as you (Robert Elz) suggested, much
> as such a custom installation may be the right thing.  Also, it looks
> like even if I do replace the zoneinfo files, time, gettimeofday, and
> clock_gettime will still behave badly on a leap second, and rewind.
>        If you just need now, there is a way that might border on nice.
>    If you need the past, more work.
> Well, a well-behaving substitute for clock_gettime, together with
> posix2time, is definitely better than having only a corrupted (i.e.,
> POSIX) clock.  There is a danger that the two will lose synchrony if
> the nearest NTP server announces a leap second that posix2time doesn't
> yet know about.  But that's less catastrophic than a self-rewinding
> clock_gettime.
>        NTP stratum ones are expected to carry a current copy of
>    in the ntp daemon's keysdir, plus the config line
>    "crypto leap leap-seconds.list".
>        Setup ntp thusly, and then...
> This looks great.  However, I went through the NTP man pages and HTML
> documentation in /usr/share/doc/html/ntp (which are pretty poorly
> synchronized, it seems), and tried various things, and couldn't figure
> out precisely what you mean by `setup ntp thusly'; in no configuration
> I tried was I able to elicit a TAI offset other than 0 from ntptime or
> ntp_gettime.  Can you be more specific?  I'd like just to configure
> ntpd on a single host -- I don't want to set up my own NTP server.

My version of ntpd didn't handle that but I
found that adding following to ntp.conf worked:

leapfile  /etc/ntp/leap-seconds.list

TAI offset remained at "0" but when I checked 
after an hour or so it had jumped to "34".


Home | Main Index | Thread Index | Old Index