NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: release 5.0.1 - build userland fails on libc ??

I thought I previously deleted all existing /usr/obj/, in order to make a
clean build...
I also do not use the update option in order to do the cleandir step, just
in case.

But anyway, always worth a try ;-)
So I did :

# find . -name "libc"
# rm -rf ./obj/lib/libc ./obj/regress/lib/libc ./obj/compat/lib/libc

and ran again.

It seems it worked... should I understand that "./ cleandir" doesnt
clean one of those ?

Worked until :

#   install  /usr/src/obj/destdir.amd64/
/usr/src/tooldir.sysupdate/bin/x86_64--netbsd-install  -N /usr/src/etc -c
-r -o root -g wheel -m 444  -a
"/usr/src/tooldir.sysupdate/bin/x86_64--netbsd-ranlib -t" libldap_pic.a
/usr/src/obj/destdir.amd64/usr/lib/i386/inst.22969a: no archive map to
x86_64--netbsd-install: running after install command on
/usr/src/obj/destdir.amd64/usr/lib/i386/inst.22969a: No such file or

*** Failed target:  /usr/src/obj/destdir.amd64/usr/lib/i386/libldap_pic.a
*** Failed command: /usr/src/tooldir.sysupdate/bin/x86_64--netbsd-install -N
/usr/src/etc -c -r -o root -g wheel -m 444 -a
"/usr/src/tooldir.sysupdate/bin/x86_64--netbsd-ranlib -t" libldap_pic.a
*** Error code 1

nbmake: stopped in /usr/src/compat/external/bsd/openldap/lib/libldap

Well I guess I ll completely "rm -rf /usr/obj" and start again, I must have
some things there not really clean....


2010/1/13 Martin Husemann <>

> On Tue, Jan 12, 2010 at 12:08:30PM +0100, Asmodehn Shade wrote:
> >
> /usr/src/tooldir.sysupdate/lib/gcc/x86_64--netbsd/4.1.3/../../../../x86_64--netbsd/bin/ld:
> > libc_pic.a( relocation R_X86_64_32 against
> > `SYS_posix_fadvise' can not be used when making a shared object;
> recompile
> > with -fPIC
> > libc_pic.a( could not read symbols: Bad value
> > collect2: ld returned 1 exit status
> Do you, by chance, have old object files (from a previous build) lying
> around
> in your object directory? If so, try removing the whole $OBJDIR/lib/libc
> directory and try again.
> Martin

Home | Main Index | Thread Index | Old Index