NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

release 5.0.1 - build userland fails on libc ??

Hi everyone,

I recently decided to update my old amd64 server from NetBSD 4 to 5.0.
I have been using NetBSD 4 on my server for quite a long time, and I was
used to build NetBSD, and I did previous update from NetBSD 2 to 3 and from
3 to 4 from source without much problems...
A script that I made long time ago to automate the update process needed
some revision, but was still working quite well.

But this time I was away from the mailing lists and news for a long time so
I probably missed some important steps in my update.
I tried to build from source NetBSD 5.0.1 on my NetBSD 4, and the build
failed, I wasnt able to build userland or the GENERIC kernel.
I tried again, after a fresh new checkout of the sources, without much

So I decided to do an upgrade from a 5.0.1 memory stick, that I built
following the instructions in the wiki. Things went well, except that I
didnt remember that my raid filesystem was FFSv2 and not v1 and I waste lots
of time before I figure out I had to use the bootxx_ffsv2 image... my bad.

Anyway, I am now running a NetBSD 5.0.1 kernel, and all the sets of the
5.0.1 release have been installed.
However I still cannot build the userland of NetBSD 5.0.1 even on a System
running 5.0.1... The error ssems to be the same as before when I was trying
to build it from NetBSD4, although I dont have any log of that anymore.

The error I get is ( at loglevel 2 on ) :

#     build  libc/
rm -f
/usr/src/tooldir.sysupdate/bin/x86_64--netbsd-gcc -nodefaultlibs
-Wl,-nostdlib -B/usr/src/obj/destdir.amd64/usr/lib/
-R/lib  -L/usr/src/obj/destdir.amd64/lib  -Wl,-x -shared
-Wl,-soname, -Wl,--warn-shared-textrel -Wl,-z,initfirst
-Wl,--fatal-warnings  -o  -Wl,--whole-archive libc_pic.a
-Wl,--no-whole-archive  -lgcc_pic  -L/usr/src/obj/destdir.amd64/usr/lib

nbmake: stopped in /usr/src/lib/libc

Interestingly enough lib/ give me a lot of compilation errors before
failing on link, that I can see clearly all together when the loglevel is
set to 0. Is that expected ?

I was wondering if someone had the same error already ? does someone has a
clue about where that might come from ? it doesnt tells me much...

Thanks a lot for the help ;)


Home | Main Index | Thread Index | Old Index