NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: release 5.0.1 - build userland fails on libc ??

As HubertF pointed to me, I forgot to redirect stderr to my log... Doh !
I also can see now that I have been imprecise : "Interestingly enough
lib/ give me a lot of compilation _*warnings*_ before failing on
link, [...]"

So I tried again today, fresh and clean....
# cd /usr/src && ./ cleandir
# rm -rf /usr/obj/destdir.amd64

and I ran my update script again, after modification to include stderr in my

Here is what I get :

/usr/src/lib/libc/rpc/xdr_rec.c(727): warning: conversion to 'int' due to
prototype, arg #3 [259]
/usr/src/lib/libc/rpc/xdr_rec.c(754): warning: conversion from 'unsigned
long' to 'unsigned int' may lose accuracy [132]
/usr/src/lib/libc/yp/xdryp.c(266): warning: conversion to 'unsigned int' due
to prototype, arg #3 [259]
/usr/src/lib/libc/yp/xdryp.c(282): warning: conversion to 'unsigned int' due
to prototype, arg #3 [259]
/usr/src/lib/libc/yp/xdryp.c(493): warning: conversion to 'unsigned int' due
to prototype, arg #3 [259]
/usr/src/lib/libc/yp/xdryp.c(512): warning: conversion to 'unsigned int' due
to prototype, arg #3 [259]
libc_pic.a( relocation R_X86_64_32 against
`SYS_posix_fadvise' can not be used when making a shared object; recompile
with -fPIC
libc_pic.a( could not read symbols: Bad value
collect2: ld returned 1 exit status

*** Failed target:
*** Failed command: /usr/src/tooldir.sysupdate/bin/x86_64--netbsd-gcc
-nodefaultlibs -Wl,-nostdlib -B/usr/src/obj/destdir.amd64/usr/lib/
-R/lib -L/usr/src/obj/destdir.amd64/lib -Wl,-x -shared
-Wl,-soname, -Wl,--warn-shared-textrel -Wl,-z,initfirst
-Wl,--fatal-warnings -o -Wl,--whole-archive libc_pic.a
-Wl,--no-whole-archive -lgcc_pic -L/usr/src/obj/destdir.amd64/usr/lib
*** Error code 1

nbmake: stopped in /usr/src/lib/libc

*** Failed target:  dependall
*** Failed command: cd /usr/src/lib/libc;
/usr/src/tooldir.sysupdate/bin/nbmake realall
*** Error code 1


A clue anyone ?
I am tracking netbsd-5-0 via cvs.

Thanks a lot,


2010/1/12 Asmodehn Shade <>

> Hi everyone,
> I recently decided to update my old amd64 server from NetBSD 4 to 5.0.
> I have been using NetBSD 4 on my server for quite a long time, and I was
> used to build NetBSD, and I did previous update from NetBSD 2 to 3 and from
> 3 to 4 from source without much problems...
> A script that I made long time ago to automate the update process needed
> some revision, but was still working quite well.
> But this time I was away from the mailing lists and news for a long time so
> I probably missed some important steps in my update.
> I tried to build from source NetBSD 5.0.1 on my NetBSD 4, and the build
> failed, I wasnt able to build userland or the GENERIC kernel.
> I tried again, after a fresh new checkout of the sources, without much
> success.
> So I decided to do an upgrade from a 5.0.1 memory stick, that I built
> following the instructions in the wiki. Things went well, except that I
> didnt remember that my raid filesystem was FFSv2 and not v1 and I waste lots
> of time before I figure out I had to use the bootxx_ffsv2 image... my bad.
> Anyway, I am now running a NetBSD 5.0.1 kernel, and all the sets of the
> 5.0.1 release have been installed.
> However I still cannot build the userland of NetBSD 5.0.1 even on a System
> running 5.0.1... The error ssems to be the same as before when I was trying
> to build it from NetBSD4, although I dont have any log of that anymore.
> The error I get is ( at loglevel 2 on ) :
> #     build  libc/
> rm -f
> /usr/src/tooldir.sysupdate/bin/x86_64--netbsd-gcc -nodefaultlibs
> -Wl,-nostdlib -B/usr/src/obj/destdir.amd64/usr/lib/
> -B/usr/src/obj/destdir.amd64/usr/lib/
> -Wl,-rpath-link,/usr/src/obj/destdir.amd64/lib:/usr/src/obj/destdir.amd64/usr/lib
> -R/lib  -L/usr/src/obj/destdir.amd64/lib  -Wl,-x -shared
> -Wl,-soname, -Wl,--warn-shared-textrel -Wl,-z,initfirst
> -Wl,--fatal-warnings  -o  -Wl,--whole-archive libc_pic.a
> -Wl,--no-whole-archive  -lgcc_pic  -L/usr/src/obj/destdir.amd64/usr/lib
> Stop.
> nbmake: stopped in /usr/src/lib/libc
> Interestingly enough lib/ give me a lot of compilation errors before
> failing on link, that I can see clearly all together when the loglevel is
> set to 0. Is that expected ?
> I was wondering if someone had the same error already ? does someone has a
> clue about where that might come from ? it doesnt tells me much...
> Thanks a lot for the help ;)
> --
> Alex

Home | Main Index | Thread Index | Old Index