NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Xorg and thinkpad x200s

On Jan 10, 2010, at 12:06 AM, Magnus Eriksson wrote:

> On Sat, 9 Jan 2010, Soren Jacobsen wrote:
>>> I assume that the precompiled binaries do not exist for these snapshots, so 
>>> that I will have to compile everything from scratch. Am I right?
>> That's correct.
> Really?  I still have packages on my system that I compiled for 1.6.  I'm not 
> on -current though, so has something happened recently?


> (So unless I am mistaken, the right answer is "yes, and no".  There aren't 
> binary packages compiled for daily snapshots, but the ones for the latest 
> release should work.  You'll get warnings that the package was compiled for a 
> different version, but that's about it.)

OK, sure, the answer is "yes, and no," but the reason I say flat out "no" above 
is that on fresh installs, as we are dealing with here, previous shared library 
majors are not present.  With your setup (upgrading the operating system over 
time), these old libraries are kept around, so there's no problem.  It isn't as 
if there's some reason current can't run binaries built for 5.0, but with no 
5.0 libraries to go with them, you're screwed.  Quite a lot of shared libraries 
have had their majors bumped since 5.0.

Home | Main Index | Thread Index | Old Index