NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: ppp unstable

On Mon, 13 Jul 2009, Jan Danielsson wrote:

And I know someone running NetBSD/i386 4.0 who is having sort of similar problems.

And that would be me. (4.0 with a fairly recent 4.0_STABLE kernel to be specific, and a Samsung phone)

When I first tried to get things up and running, there were some timing problems in getting NetBSD to talk to the phone; i.e. the chat script sometimes left things in a state which didn't get me a connection. I tried repeatedly running "ppp stop" and "ppp start", but after some number of tries this left me with a hard lockup. Or what seemed like one at least, I was using X and have no idea what the console might have said.

After the chat script problems were worked out, things were fine for a while. But since the connection is reset every day, I have to restart it regularly. And after about a week, another hard lockup.

David Wetzel:

It worked on a PC Engines ALIX but I had to unplug the USB at least once a day.

I have started unplugging and reattaching the phone at least once every 2-3 days. No problems whatsoever since, and it has been at least three or four weeks of uninterrupted uptime.


I am using a HUAWEI_E220 with current and had 0 panics. I am even unplugging the card while pppd is running and connected. It is extremely stable for me. In fact I travelled 2 hours from Long Island to New York and it kept the connection up all the time.

Same here really. The phone is my sole net connection, and it is regularly up for 20+ hours at a time; that is not a problem. Repeatedly bringing the connection up and down seems to be what kills things, but I should probably investigate some more (and try to crash things that way).


Home | Main Index | Thread Index | Old Index