NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Freezing with ATI Radeon 9800 (NetBSD/amd64 4.0)

Jean-Yves Migeon wrote:
Try disabling agp fast write and see if it changes anything:

Section "Device"
   Identifier  "Radeon"
   Driver      "radeon"
   Option      "AGPFastWrite" "false"

Just tried that -- no luck. Thanks for the suggestion, though.

I then decided to reinstall NetBSD and use the provided XF86 binary set. It worked. xf86cfg generated this config:

Unlike Xorg, it didn't require a modeline for the resolution to be set properly.

I was ready to conclude the problem was software, then I rebooted into Windows.

Twice in a row Windows froze when the high-res mode kicked in. It worked on the third time.

So the problem is hardware, but it only reveals itself with Xorg or occasionally with Windows. I suppose it might happen sometimes with Xf86 too.

I guess I can either replace it now or use Xf86/Windows and tolerate some hiccups.

-Alex Hanson

Home | Main Index | Thread Index | Old Index