Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD on Gateway SX2185?

On Sun, 27 Jul 2014, Jean-Yves Migeon wrote:

Interestingly, I tried with hd1 and I got the same errors from the
chainloader commands.  But

     grub> set root=(hd1)
     grub> ls /
     error: file `/boot/grub/x86_64-efi/zfs.mod' not found
     (repeats for tar, sfs, nilfs2, minix, afs, and affs modules)
     error: unknown file system

Hmmm. And what happends when you try ls (hd1,0,a)/boot in this case?

More interesting stuff...

If I type

        grub> set root=(hd1<TAB>

I get the following stuff:

        Possible partitions are:

        Device hd1: No known filesystem detected - Sector size 512B - Total
        size 78150744KiB
        Partition hd1,netbsd1: Filesystem type ufs1, (various fs stats)
        Partition hd1,netbsd2: No known filesystem detected, ...
        Partition hd1,netbsd4: No known filesystem detected, ...
        Partition hd1,netbsd5: Filesystem type ufs1, ...
        Partition hd1,msdos1: Filesystem type ufs1, (same stats as netbsd1)

So, I tried

        grub> set root=(hd1,netbsd1)
        grub> ls /

And it gives a list of what is/should be in the root directory.


        grub> chainloader +1
        error: not a valid root device
        grub> kernel netbsd-GENERIC
        error: can't find command `kerne;'

| Paul Goyette     | PGP Key fingerprint:     | E-mail addresses:       |
| Customer Service | FA29 0E3B 35AF E8AE 6651 | paul at    |
| Network Engineer | 0786 F758 55DE 53BA 7731 | pgoyette at |
| Kernel Developer |                          | pgoyette at  |

Home | Main Index | Thread Index | Old Index