Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Netbooting a sparc64 (netbsd-6)

On Feb 27, 2012, at 21:15 , Chris Ross wrote:
>> There is an easy way to verify the problem I had in mind: connect another
>> port as well and use that to netboot - e.g. have the prom use bge1 to load
>> the kernel, then the kernel will be able to use bge0.
>  The first attempt to do this, with a manual "move the cable between ports, 
> and use the same IP address for both" didn't work.  If I get too much 
> further, I'll make a new cable (it's a long run, this server isn't in the 
> service area/room/closet yet) and try it the hard way.  Would you suggest 
> using two different IP addresses, given that there are two MACs ?

  In case this helps, continuing the "switch the cable and wait, after the 
kernel fails to mount the nfs filesystem".

  I loaded the bootloader via tftp, and the kernel via NFS, over bge1.  Then, 
after the kernel loads and fails to configure bge1, I switched the cable to 
bge0.  I waited a while, checked that the arp cache on the router didn't have 
anything, and cleared it on the NFS (/rarpd/tftpd) server.  I told the sparc to 
use bge0, and it claims to be trying to get an address via DHCP/BOOTP, but 
there is never any traffic from the mac(s) on that machine [seen by the 
router/DHCP server].

  So, it looks more like this version of the kernel (netbsd-6, circa 25-Feb) 
just isn't passing packets at all.  So, with the kernel in question, I loaded 
the 5.99.59 userland I had on a disk.  I then tried to dhcpcd from it, and also 
saw nothing on the dhcp server.

  So.  I then cold-booted into the 5.99.59 image on the disk, which was never 
really fully configured.  It's in full Amnesiac mode.  If I run dhcpcd on bge0, 
it gives up assigning a 169.254/16 address, my dhcpd never having seen a 
packet.  But, if I kill dhcpcd and manually configure an address, it seems to 
pass packets, on net and through the router.

  This is smelling more like a sparc64 bge bug as time goes on...

  Anyone have any new thoughts or suggestions?

              - Chris

Home | Main Index | Thread Index | Old Index