Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: problem

vincent <> writes:

> vincent# ./ -O obj -D bsd -T mytools build release

I have never tried to use non-absolute paths here.  Are those
directories empty when you start?

> ===> command: ./ -O obj -D bsd -T mytools build release
> ===> started: Fri Apr  3 14:13:59 CEST 2009
> ===> NetBSD version:   5.99.9
> ===> MACHINE:          amd64
> ===> MACHINE_ARCH:     x86_64
> ===> Build platform:   NetBSD 5.99.01 amd64
> ===> HOST_SH:          /bin/sh
> ===> No /usr/src/mytools/bin/nbmake, needs building.
> ===> Bootstrapping nbmake
> /bin/sh: Can't open /usr/src/tools/make/configure
> ERROR: Configure of nbmake failed

gdt 115 ~ > l /usr/src/tools/make
total 92
drwxr-xr-x  2 gdt  users    512 Nov  4 13:02 CVS
-r--r--r--  1 gdt  users    296 Oct 14  2007 Makefile.regen
-r-xr-xr-x  1 gdt  users    531 Aug 28  2006
-r-xr-xr-x  1 gdt  users  85306 Oct 24  2007 configure
-r--r--r--  1 gdt  users   1834 Oct 24  2007

gdt 121 /usr/src/tools/make > cvs status configure
File: configure         Status: Up-to-date

   Working revision:    1.8
   Repository revision: 1.8     /cvsroot/src/tools/make/configure,v
   Sticky Tag:          netbsd-5 (branch: 1.8.12)
   Sticky Date:         (none)
   Sticky Options:      (none)

so your sources seem messed up.

rest of this advice still applies, but I think your problem is not about

> Same thing. Keeping things separated, okay, but for what purpose? I
> use but one tree, and those commands have perfectly worked until now.
> It ceased working with the last cvs update (before, I got a
> compilation error, but the script did work...).

I build for multiple architectures and releases on the same machine (for
binary updating of other boxes), and I like to always do things the same
way on every machine, even those with only one tree.  I see multiple
trees as normal and one tree as a special case.

> I'm going to dig in by trying to see exactly what happens inside the
> script...

I would try putting 'set -x' in, or running sh -x and
then following what it does.

You might try

  installing sysutils/etcmanage from pkgsrc head
  make sure /usr/obj is writeble by you and has space
  in the directory with src (and xsrc, but you are not building with X11)
    $ echo auto > .tree
    $ BUILD-NetBSD all &> B000.all &

I suspect that will get you the full build you are looking for if you
are really having problems - but it won't answer the question of
what's wrong.

Attachment: pgpHfB_jesGQh.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index