Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Who changed the bootloader recently?

Hisashi T Fujinaka wrote:
On Mon, 20 Oct 2008, Joerg Sonnenberger wrote:

On Sun, Oct 19, 2008 at 05:36:50PM -0700, Hisashi T Fujinaka wrote:
I have a Frankensteined NetBSD with grub so I can remotely boot NetBSD,
FreeBSD, and Linux. So as of a couple of weeks ago, grub can't boot NetBSD.

I fixed a bug in that yesterday, does it still not work?
NetBSD was missing the multiboot header. You should still have been able
to boot with --type=netbsd though.

I used the weird workaround where I didn't specify a root, but just
chainloader +1. I didn't think about --type=netbsd because that never
worked for me before.

Both work for me with Grub with MULTIBOOT defined in the kernel:

title           NetBSD CURRENT
root            (hd0,3,a)
kernel          (hd0,3,a)/netbsd bootdev=wd0a

# Chain load NetBSD kernel
title NetBSD - Chainloader rootnoverify (hd0,3,a) chainloader +1 makeactive

Home | Main Index | Thread Index | Old Index