Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: WARNING: module error: builtin module `putter' failed to init

2008/5/27 Jared D. McNeill <>:
> Chavdar Ivanov wrote:
>> 2008/5/27 Jared D. McNeill <>:
>>> Chavdar Ivanov wrote:
>>>> 2008/5/27 Andrew Doran <>:
>>>>> On Tue, May 27, 2008 at 01:55:36AM +0200, Adam Hoka wrote:
>>>>>> After compiling a custom kernel I have found the following in my
>>>>>> dmesg:
>>>>>>  WARNING: module error: builtin module `drm' failed to init
>>>>>>  WARNING: module error: builtin module `putter' failed to init
>>>>> FWIW, the module is not initializing because its char/block device has
>>>>> already been hooked in by the glue generated by config(1). Two ways to
>>>>> achieve the same thing and one wins. It's harmless. Some #ifdefs would
>>>>> sort
>>>>> the warning, but we need to do some serious work on the kernel config
>>>>> scheme
>>>>> to handle both modules and static builds well.
>>>> I am seeing the same. If I take out the corresponding lines in my
>>>> GENERIC.local, do I have to do something to enable/use the kernel
>>>> modules? I haven't seen a panic - I am using drm only at this time.
>>> 1. cd sys/modules, make and make install
>>> 2. set MKMODULAR=yes in /etc/mk.conf
>>> 3. for each of sbin/modload sbin/modunload and sbin/modstat:
>>>       USETOOLS=no make clean
>>>       USETOOLS=no make
>>>       sudo USETOOLS=no make install
>>> 4. modload <driver>, currently i915drm and radeondrm are available on
>>> i386.
>>> i915drm is available on amd64 but there are stability problems running it
>>> from a module.
>>> Cheers,
>>> Jared
>> Thanks, all worked as expected. One less thing to modify in the kernel
>> config...
>> I can't load radeondrm on my office Kayak - it's a 9800SE, which
>> apparently is RV350 (AFAIU drm supports RV200 and RV300, am I right?).
>> I am getting:
>> WARNING: module error: unable to affix module.
>> But then when I had radeondrm in the kernel config file, everything
>> showed OK in the dmesg, but drm never actually worked - glxgears would
>> just freeze the X output, just the mouse cursor remained moving.
> Does /stand/i386/4.99.63/modules/drm/drm.kmod exist? Does modstat show it as
> loaded?

It does, but I forgot to modload it - which I did for the i915drm test.

Now it loads both modules:

% /sbin/modstat| grep drm
drm             misc    filesys 0       41558   -
radeondrm       driver  filesys 0       118598  -
17:07 (ci~loan8) /home/ci
% dmesg|grep drm
drm at vga1 not configured
radeondrm0 at vga1: ATI Radeon AH 9800 SE (unit 0)
radeondrm0: AGP at 0xe0000000 256MB
radeondrm0: Initialized radeon 1.26.0 20060524
info: [drm] Setting GART location based on new memory map
info: [drm] Loading R300 Microcode
info: [drm] writeback test succeeded in 1 usecs
radeondrm0: interrupting at ioapic0 pin 16
17:07 (ci~loan8) /home/ci

glxinfo confirms Direct rendering, but glxgears freezes the screen as
per the previous mail. I don't think this is anything to do with the
modules themselves, though - I am getting in Xorg.0.log :

(==) RADEON(0): Backing store disabled
(II) RADEON(0): [DRI] installation complete
(II) RADEON(0): [drm] Added 32 65536 byte vertex/indirect buffers
(II) RADEON(0): [drm] Mapped 32 vertex/indirect buffers
(II) RADEON(0): [drm] dma control initialized, using IRQ 11
(II) RADEON(0): [drm] Initialized kernel GART heap manager, 5111808
(WW) RADEON(0): DRI init changed memory map, adjusting ...
(WW) RADEON(0):   MC_FB_LOCATION  was: 0xd7ffd000 is: 0xd7ffd000
(WW) RADEON(0):   MC_AGP_LOCATION was: 0xffffffc0 is: 0xe07fe000
(II) RADEON(0): RADEONRestoreMemMapRegisters() :
(II) RADEON(0):   MC_FB_LOCATION   : 0xd7ffd000 0xd7ffd000
(II) RADEON(0):   MC_AGP_LOCATION  : 0xe07fe000
(II) RADEON(0): Direct rendering enabled
(II) RADEON(0): Render acceleration unsupported on Radeon 9500/9700 and newer.
(II) RADEON(0): Render acceleration disabled
(II) RADEON(0): Using XFree86 Acceleration Architecture (XAA)

which probably means 'tough chance' for now.

Anyway, the kernel modules seem to work just fine.

BTW, there is /usr/bin/modstat, which returns nothing - I wonder what
is it and if it is still required.

% /usr/bin/modstat
Type    Id   Offset Loadaddr Size Info     Rev Module Name

> Cheers,
> Jared

/dev/random says:
        I always lie. In fact, I'm lying to you right now!
Chavdar Ivanov | Talbot Way, Small Heath Business Park
Delcam UK | Birmingham B10 0HJ, United Kingdom
Customer Support | (+44)121-6831014

Home | Main Index | Thread Index | Old Index