Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: WARNING: module error: builtin module `putter' failed to init

2008/5/27 Jared D. McNeill <>:
> Chavdar Ivanov wrote:
>> 2008/5/27 Andrew Doran <>:
>>> On Tue, May 27, 2008 at 01:55:36AM +0200, Adam Hoka wrote:
>>>> After compiling a custom kernel I have found the following in my dmesg:
>>>>  WARNING: module error: builtin module `drm' failed to init
>>>>  WARNING: module error: builtin module `putter' failed to init
>>> FWIW, the module is not initializing because its char/block device has
>>> already been hooked in by the glue generated by config(1). Two ways to
>>> achieve the same thing and one wins. It's harmless. Some #ifdefs would
>>> sort
>>> the warning, but we need to do some serious work on the kernel config
>>> scheme
>>> to handle both modules and static builds well.
>> I am seeing the same. If I take out the corresponding lines in my
>> GENERIC.local, do I have to do something to enable/use the kernel
>> modules? I haven't seen a panic - I am using drm only at this time.
> 1. cd sys/modules, make and make install
> 2. set MKMODULAR=yes in /etc/mk.conf
> 3. for each of sbin/modload sbin/modunload and sbin/modstat:
>        USETOOLS=no make clean
>        USETOOLS=no make
>        sudo USETOOLS=no make install
> 4. modload <driver>, currently i915drm and radeondrm are available on i386.
> i915drm is available on amd64 but there are stability problems running it
> from a module.
> Cheers,
> Jared

Thanks, all worked as expected. One less thing to modify in the kernel config...

I can't load radeondrm on my office Kayak - it's a 9800SE, which
apparently is RV350 (AFAIU drm supports RV200 and RV300, am I right?).
I am getting:

WARNING: module error: unable to affix module.

But then when I had radeondrm in the kernel config file, everything
showed OK in the dmesg, but drm never actually worked - glxgears would
just freeze the X output, just the mouse cursor remained moving.

I alsi tested putter and puffs with psshfs OK.


/dev/random says:
        I always lie. In fact, I'm lying to you right now!
Chavdar Ivanov | Talbot Way, Small Heath Business Park
Delcam UK | Birmingham B10 0HJ, United Kingdom
Customer Support | (+44)121-6831014

Home | Main Index | Thread Index | Old Index