tech-pkg archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: First go at adding GCC_VERSIONS_ACCEPTED support

Only just catching up with these emails now, sorry

On 27-Sep-2015 21:54:24, Greg Troxel wrote:

David Sainty <> writes:

I think what it doesn't do is take note that if the native compiler is
4.4, the package needs 4.5, and gcc48 happens to be installed then it
could use gcc48 - it'll install gcc45 instead.  Is that what you have
in mind?

Yes, that's more or less what I meant.

This is exactly my motivation as well.

What would be nice is being able to explicitly set something like
PKGSRC_GCC_MIN in /etc/mk.conf to 4.8, to tell Pkgsrc that if it's
going to install a GCC package (I.e. native compiler isn't enough)
then jump straight up to 4.8.

In fact, if a user-mk.conf-settable PKGSRC_GCC_MIN was supported, and
GCC_REQD was left as it is, I think all my personal use cases would be
satisfied :)  Is there a compelling use case for something more

Your notion of the user giving a version to jump to beyond the system
version sounds sensible, to avoid the mixing issue (both from failures
and the pain of building many versions).

I'd be fine with this too.

I'm still happy to carry on having a go at implementing whatever is needed. But I'm not sure what the consensus is on the approach required?

Do we still want a list of incompatible versions? And a PKGSRC_GCC_MIN?

Home | Main Index | Thread Index | Old Index