[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
Re: First go at adding GCC_VERSIONS_ACCEPTED support
On 02/10/15 10:45, atomicules wrote:
On 27-Sep-2015 21:54:24, Greg Troxel wrote:
David Sainty <david.sainty%gmail.com@localhost> writes:
I think what it doesn't do is take note that if the native compiler is
4.4, the package needs 4.5, and gcc48 happens to be installed then it
could use gcc48 - it'll install gcc45 instead. Is that what you have
Yes, that's more or less what I meant.
This is exactly my motivation as well.
Do we still want a list of incompatible versions?
I have one (and only one) example I can give where this would have been
useful in theory. But using an incompatible versions feature would have
been so messy that I think it's a counterexample for supporting
inkscape used to have GCC_REQD+=3.0, but recent versions have caused
internal compiler errors in GCC 4.3 through GCC 4.5.1.
In theory, a list of incompatible versions could have allowed GCC 3.0 to
be used, or GCC 4.5.2, but exclude GCC 4.3.
In practice, setting GCC_REQD+=4.5.2 is much simpler, and I'm just not
sure there's much reason to care too much about machines running (E.g.)
GCC 3.1. It's also increasingly hard to test the support of running
inkscape on an Analytical Engine running GCC 3.1.
Main Index |
Thread Index |