Port-sparc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Anyone have working pre-v8 machines?

>> ...?  8.x and 9.x don't boot at all?  Not netboot?  Not even if you
>> put the data on the disk with another machine?  [...]

> To be honest, I did not try netbooting.  It is always a hassle, but
> could be a nice to test to be sure that the "only" problem is the
> boot blocks

Netbooting is one of my first go-to alternatives for booting troubles,
but in my case I have a machine already set up specifically to be a
netboot (RARP, DHCP, NFS, etc) server.

> I did not try yet "installing" from another machine, perhaps I could
> use my other sparcstation, put the hard disk in an enclosure and try
> installing on it?

Possibly.  I would prefer that myself anyway, because I don't like to
run disks inside my SS20s for heat dissipation reasons.  (I have two
SS20s in routine live use right now and in each case the disk is

> I avoid that if possiblethouhg, I do not like moving in-out of hard
> disks on these old machines, connectors and 50pins are brittle.

I thought the SS20's internal disk connectors were SCA, not 50-pin.  Am
I misremembering?

> Also, I fear if the installer does not load, why should the installed
> system load better?

Maybe it won't.  But I've seen cases where one loads and the other
doesn't often enough in the past that I tend to be suspicious.

Also, some people, when writing to the list, do not draw any
distinction between "install media bootblocks error out" and "install
kernel errors out" and "installer runs but installed booter fails" and
the like; it all ends up described as as "I tried to install and it
didn't work".  Suggesting alternatives and asking for details often
clarifies exactly what's breaking.

>> What goes wrong when you try?
> Data access exception.  It appears to be the same issue I had in
> 2014.

> Many years ago I was able to "install" but not boot again and somehow
> I tested many boot blocks until I found one that worked and "kept"
> it.  Until I decided to upgrade again...

I don't know whether it's relevant to your particular case, but I do
know that there have been times, on some architectures, when bootblocks
older than a certain change can't load kernels newer than that change,
or when bootblocks older than time T1 can't load kernels bigger than
some size, and at a time later than T1 the kernel grew to exceed that
size, or the like.

I don't recall trying anything even vaguely recent on my SPARCs (the
most recent I've tried is, I think, 5.2), so I have no relevant
personal experience.  I could probably grab a scratch disk and do a
test install of 9.x on it, but probably not very soon.

/~\ The ASCII				  Mouse
\ / Ribbon Campaign
 X  Against HTML		mouse%rodents-montreal.org@localhost
/ \ Email!	     7D C8 61 52 5D E7 2D 39  4E F1 31 3E E8 B3 27 4B

Home | Main Index | Thread Index | Old Index