Port-prep archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: PCI expansion card working?

Hi! Tim,

I apologize slow reply.  :-<

From: KIYOHARA Takashi <kiyohara%kk.iij4u.or.jp@localhost>
Date: Sun, 20 Jan 2008 01:55:25 +0900 (JST)

> From: Tim Rightnour <root%garbled.net@localhost>
> Date: Fri, 18 Jan 2008 23:20:55 -0700 (MST)

> > Have you tried pulling the cards out one at a time to see if any particular 
> > one
> > causes the problem, or do they all cause it individually?
> It is only fwohci+ehci card that doesn't work with the card that I have.
> Because bktr(4) doesn't interrupt when starting, and not have X, it
> doesn't confirm it. 
> I exchange the card of this prep for the card to other machines.(i386,
> macppc, cobalt, alpha, bebox ;-)

I tried booting with other cards.  Interrupt was not similarly generated
on several cards.  It had hung up in a certain card before pnpbus(4) was
attached after it had attached of cpu(4).

  cpu0: HID0 c084<ICE,DCE,SGE,BHT>, powersave: 1
  cpu0: 133.33 MHz
  cpu at mainbus0 not configured
                                        <-- hangup here
  pnpbus0 at mainbus0                   <-- this message not look

And, it starts booting in two cards of different fwohci(4) and ehci(4).
However, the panic was done in this case because of a different error.

I will once more try with PCI_CONF_DUMP at tonight.


>> NetBSD/prep BOOT, Revision 1.8
>> (builds@wb40, Thu Nov  8 01:45:46 PST 2007)

Loading in()

Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005,
    2006, 2007, 2008
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.

NetBSD 4.99.49 (JUSTICE) #0: Mon Jan 21 11:01:38 JST 2008
Model: IBM PPS Model 7248 (E)
total memory = 128 MB
avail memory = 120 MB
mainbus0 (root)
cpu0 at mainbus0: 604 (Revision 3.4), ID 0 (primary)
cpu0: HID0 c084<ICE,DCE,SGE,BHT>, powersave: 1
cpu0: 133.33 MHz
cpu at mainbus0 not configured
pnpbus0 at mainbus0
wdc0 at pnpbus0: port 0x1f0-0x1f7 0x3f6, irq 13, DMA 6
atabus0 at wdc0 channel 0
wdc1 at pnpbus0: port 0x170-0x177 0x376, irq 13, DMA 7
atabus1 at wdc1 channel 0
mcclock0 at pnpbus0: port 0x70-0x71, irq 8: mc146818 compatible time-of-day 
nvram0 at pnpbus0: port 0x74-0x75 0x76
pci0 at mainbus0 bus 0: indirect configuration space access
pchb0 at pci0 dev 0 function 0
pchb0: Motorola MPC105 "Eagle" Host Bridge (rev. 0x24)
pchb0: L2 cache: 512K, write-through mode
pcib0 at pci0 dev 11 function 0: IBM Fire Coral ISA Bridge w/PnP (rev. 0x02)
pcn0 at pci0 dev 12 function 0: AMD PCnet-PCI Ethernet
pcn0: Am79c970A PCnet-PCI II rev 6, Ethernet address 08:00:5a:f8:7c:23
pcn0: interrupting at irq 15
pcn0: 10base5, 10base5-FDX, 10baseT, 10baseT-FDX, auto, auto-FDX
vga0 at pci0 dev 14 function 0: S3 86C864-1 ("Vision864") (rev. 0x00)
wsdisplay0 at vga0 kbdmux 1
direct rendering for vga0 unsupported
siop0 at pci0 dev 16 function 0: Symbios Logic 53c810 (fast scsi)
siop0: interrupting at irq 15
scsibus0 at siop0: 8 targets, 8 luns per target
ohci0 at pci0 dev 18 function 0: NEC USB Host Controller (rev. 0x41)
ohci0: interrupting at irq 15
ohci0: OHCI version 1.0
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
ohci1 at pci0 dev 18 function 1: NEC USB Host Controller (rev. 0x41)
ohci1: interrupting at irq 15
ohci1: OHCI version 1.0
usb1 at ohci1: USB revision 1.0
uhub1 at usb1
uhub1: NEC OHCI root hub, class 9/0, rev 1.00/1.00, addr 1
ehci0 at pci0 dev 18 function 2: NEC USB Host Controller (rev. 0x01)
ehci0: interrupting at irq 15
ehci0: companion controllers, 3 ports each: ohci0 ohci1
usb2 at ehci0: USB revision 2.0
uhub2 at usb2
uhub2: NEC EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
fwohci0 at pci0 dev 22 function 0: VIA Technologies VT6306 IEEE 1394 Host 
Controller (rev. 0x43)
fwohci0: interrupting at irq 15
fwohci0: OHCI version 1.0 (ROM=1)
fwohci0: No. of Isochronous channels is 8.
fwohci0: EUI64 0c:10:11:00:00:00:04:6d
fwohci0: Phy 1394a available S400, 3 ports.
fwohci0: Link S100, max_rec 2 bytes.
fwohci0: max_rec 2 -> 2048
ieee1394if0 at fwohci0: IEEE1394 bus
fwip at ieee1394if0 not configured
fwohci0: Initiate bus reset
isa0 at pcib0
lpt0 at isa0 port 0x3bc-0x3bf irq 7
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
com0: console
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
pckbc0 at isa0 port 0x60-0x64
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0 mux 1
attimer0 at isa0 port 0x40-0x43: AT Timer
pcppi0 at isa0 port 0x61
midi0 at pcppi0: PC speaker (CPU-intensive output)
spkr0 at pcppi0
isabeep0 at pcppi0
isapnp0 at isa0 port 0x279: ISA Plug 'n Play device support
pcppi0: attached to attimer0
wss0 at isapnp0 port 0x534/4,0x388/4,0x220/16 irq 5 drq 1,0
wss0: Crystal CS4232 Sound Chip : broken
audio0 at wss0: full duplex, mmap
opl at wss0 not configured
isapnp0: <Crystal CS4232 Sound Chip, CSC0001, , > port 0x200/8 not configured
isapnp0: <Crystal CS4232 Sound Chip, CSC0002, , 4232> port 0x10/8 not configured
isapnp0: <Crystal CS4232 Sound Chip, CSC0003, , > port 0x330/2 irq 9 not 
isapnp0: <Crystal CS4232 Sound Chip, CSC0004, , CD-ROM> port 0x10/4 not 
biomask 80000ce netmask 80000ce ttymask 80000ce
fwohci0: BUS reset
fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
ieee1394if0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
ieee1394if0: bus manager 0 (me)
scsibus0: waiting 2 seconds for devices to settle...
sd0 at scsibus0 target 0 lun 0: <CONNER, CFP2105S  2.14GB, 1524> disk fixed
sd0: 2048 MB, 3940 cyl, 10 head, 106 sec, 512 bytes/sect x 4194304 sectors
sd0: sync (100.00ns offset 8), 8-bit (10.000MB/s) transfers, tagged queueing
cd0 at scsibus0 target 3 lun 0: <IBM, CDRM00203\000\000\000\000\000!K, BZ26> 
cdrom removable
cd0: sync (200.00ns offset 8), 8-bit (5.000MB/s) transfers
boot device: sd0
root on sd0a dumps on sd0b
root file system type: ffs
Mon Jan 21 02:26:53 GMT 2008
swapctl: adding /dev/sd0b as swap device at priority 0
Checking for botched superblock upgrades: done.
Starting file system checks:
/dev/rsd0a: file system is clean; not checking
/dev/rsd0f: file system is clean; not checking
/dev/rsd0g: file system is clean; not checking
Setting tty flags.
Setting sysctl variables:
Starting network.
Hostname: justice.fool
IPv6 mode: host
Configuring network interfaces: pcn0trap: kernel read DSI trap @ 0x7c68055e by 
0x2e71f8 (DSISR 0x40000000, err=14), lr 0x2994f4
panic: trap
Stopped in pid 117.1 (ifconfig) at      netbsd:cpu_Debugger+0x10:       lwz     
0, r1, 0x14
db> bt
0xda724760: at panic+0x1b4
0xda7247b0: at trap+0x100
0xda724840: kernel DSI read trap @ 0x7c68055e by pcn_79c970_mediachange+0x18: sr
            r1=0xda724900 cr=0x44008022 xer=0 ctr=0x2e71e0 dsisr=0x40000000
0xda724900: at _prop_array_pool+0xcfcc6ccc
0xda724920: at ifmedia_change+0x18
0xda724930: at mii_ifmedia_change+0x10
0xda724940: at pcn_init+0x6f8
0xda724990: at ether_ioctl+0x15c
0xda7249b0: at pcn_ioctl+0x7c
0xda7249e0: at in6_update_ifa+0x508
0xda724ad0: at in6_ifattach+0x268
0xda724c60: at in6_if_up+0x8c
0xda724c80: at if_up+0x34
0xda724ca0: at ifioctl+0xa44
0xda724e10: at soo_ioctl+0x260
0xda724e20: at sys_ioctl+0x11c
0xda724ee0: at syscall_plain+0x1ac
0xda724f40: user SC trap #54 by 0xeff84628: srr1=0xd032
            r1=0xffffce30 cr=0x44004024 xer=0x20000000 ctr=0xeff84620
db> ~

Home | Main Index | Thread Index | Old Index