Port-i386 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD/i386 8.0 RC1 Vs. VIA C3


Tested more thoroughly:

apm -S hangs the system with the only message "acpi0: entering state
S0" visible.

apm -z crashes.

If S1&S3 mode in BIOS:

acpi0: entering state S3
Flushing disk caches: 1 done
fatal page fault in supervisor mode
trap type 6 code 0 eip 0xc04fcab9 cs 0x8 eflags 0x210206 cr2 0x7d
ilevel 0x6 esp 0xc0dd70e0
curlwp 0xc3155d20 pid 0 lid 2 lowest kstack 0xdaaf02c0
panic: trap
cpu0: Begin traceback...
at netbsd:vpanic+0x121
at netbsd:snprintf
trap() at netbsd:trap+0xc80
--- trap (number 6) ---
at netbsd:pckbcintr+0x6e
intr_biglock_wrapper(c326f438,daaf1ee8,0,0,0,0,0,0,0,0) at
--- switch to interrupt stack ---
Xintr_ioapic_edge9() at netbsd:Xintr_ioapic_edge9+0xb5
--- interrupt ---
at netbsd:x86_stihlt+0x5
at netbsd:acpicpu_cstate_idle_enter+0xdf
at netbsd:acpicpu_cstate_idle+0xa8
idle_loop(c3155d20,1067000,1070000,0,c01003f8,0,0,0,0,0) at
cpu0: End traceback...


If S3 only enabled in BIOS:

acpi0: entering state S3
Flushing disk caches: done
fatal protection fault in supervisor mode
trap type 4 code 0 eip 0xc012dc8b cs 0x8 eflags 0x210046 cr2
0xdafc35b2 ilevel 0x8 esp 0xc3292800
curlwp 0xc3269540 pid 0 lid 17 lowest kstack 0xdab272c0
panic: trap
cpu1: Begin traceback...
at netbsd:vpanic+0x121
at netbsd:snprintf
trap() at netbsd:trap+0xc80
--- trap (number 4) ---
at netbsd:acpi_md_sleep_prepare+0x37
x86_ipi_handler(dab28f10,0,0,0,0,0,0,0,0,0) at netbsd:x86_ipi_handler+0x59
DDB lost frame for netbsd:Xresume_lapic_ipi+0x25, trying 0xdab4df78
Xresume_lapic_ipi() at netbsd:Xresume_lapic_ipi+0x25
--- interrupt ---
cpu1: End traceback...

And vge0 (integrated intel 1GBit NIC) starts to spit "vge0: setting
CAM filter failed error" until I completely turn off power from the

On Wed, Jun 6, 2018 at 10:57 AM, Andrius V <vezhlys%gmail.com@localhost> wrote:
> Hi,
> S1 state can be possibly enabled in BIOS?  VT310-DP has an options to
> enable S1, S3 or S1&S3. I tried apm -z on my system  (VT310-DP), it
> ended up with system crash... However, I have never tried to use
> suspend before, possibly the issue is not new. Will try apm -S later
> on.
> On Tue, Jun 5, 2018 at 12:00 AM, Andy Ball <ball%grex.org@localhost> wrote:
>> Hello,
>>     Today I tried NetBSD/i386 8.0 RC1 on a VIA EPIA M10000
>> mainboard (1 GHz C3 Nehemiah, 1GB RAM, 40 GB disk).  Sleep
>> and suspend don't work...
>>   $apm -S
>>   spkr0 at audio0: PC Speaker (synthesized)
>>   acpi0: entering state S1
>>   acpi0: sleep state S1 is not available
>> ...host continues to operate.
>>   $apm -z
>>   System will enter suspend mode in a moment.
>>   spkr0 at audio0: PC Speaker (synthesized)
>>   acpi0: entering state S3
>>   Flushing disk caches: done
>> ...disk spins down, host fails to enter standby state and
>> hangs.  I have to cycle power to bring the host back up.
>> - Andy Ball.

Home | Main Index | Thread Index | Old Index