Port-hpcmips archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Workpad Z50 install issue

On Fri, Mar 27, 2015 at 3:59 PM, Larry Stotler <larrystotler%gmail.com@localhost> wrote:

I recently acquired a pristine Z50 with the 32MB RAM upgrade.
everything seems to work with no issues.  I've been using Linux for 16
years, but have little experience with NetBSD and am looking forward
to learning.

I have a 2GB Compact Flash card that I split in half, first half for
FAT16 and the rest for NetBSD.  I'm using a 3COM Etherlink III 10BaseT
network card.

I tried installing NetBSD from the dos partition but could not figure
out how to mount it.  So,

I tried installing over NFS.  It started installing but when I get to
the base.tgz package, it fails.  So, thinking there might be an issue
with the iso I downloaded,

I am now trying to install via FTP.  The first 2 packages have
installed, but it is still failing on base.tgz.

The error I am now getting is:

zip: data stream error
tar: End of archive volume 1 reached
tar: Unexpected EOF on archive file

at 20%.  I was getting a different error but now can't duplicate that one.

Could the CF card be bad?  I'm probably going to get a newer card
and/or a microdrive as well.

Any suggestions would be greatly appreciated.

Also, can anyone suggest a really good guide for using NetBSD and/or
how it differs from Linux?  I find myself trying Linux commands that
don't work under BSD and don't have any idea what the equivalents are.

cat /proc/cpuinfo
cat /proc/meminfo

Netbsd drive structure vs Linux's sdx

Not much traffic on this list lately.

There was some talk on another mips based mail list about some instabilities, try reading the cobalt list.

I used to play with NEC Mobilepro but it's been years ago now. I used a microdrive with good results, they were much quicker than the CF cards of the time (minus the spinup latency). Don't know if this is still true.

If you want basic info on the cpu and memory, just look at the top part of the dmesg. I noticed that my i386 machine has cpuinfo and meminfo in the /proc filesystem, but my arm machine does not. Must be a platform specific thing. Don't know if mips has this info in proc.

The disk numbering is similar except you reverse the last two characters (sort of). In linux you see /dev/sda1, in NetBSD it would be /dev/sd1a, although the 1 and the a are not referring to the same thing. The a in NetBSD is a slice on the disklabel, not a partition. See the fdisk and disklabel man pages.

I used to use this "unix" rosetta stone type of thing a long time ago, but I don't know if there is something newer:


I've been using NetBSD so long that I'm probably not a good one to speak to learning about it.


Home | Main Index | Thread Index | Old Index