Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD evbarm - Help with Raspberry Pi 4 installation and build

Your website was very useful in documenting the steps you took to obtaining a working NetBSD instance on the Rpi4. In fact, I'd followed a similar process through my own experimentation. Unfortunately though, following your process gives the same result: the system boots, but hangs at:

	armgic0: 16 priorities, 224 SPIs, 7 PPIs, 16SGIs

I have updated the RPI's EEPROM by booting Raspian from SD card, and the device does seem to be reading and booting from USB fine. 

I am using the May 4 build of NetBSD aarch64, and have tried different versions of the UEFI firmware ranging from 1.22 to 1.26, all with the same result. The only difference is that I am not using a serial terminal and am using the console instead.

To clarify, this is on a 4GB model. Ebijun's images seem to work fine, but I am having trouble understanding the build scripts as there's not a lot of documentation on how to actually run the build process. I'm hesitant to use them as they have a lot of things installed I don't need (Twitter API keys, for example). 

Thanks for your help though!

> On 5 May 2021, at 4:50 am, Chris <chris%ultralight.cc@localhost> wrote:
> I'm using NetBSD current on a 8GB RPi4 booting directly from a USB SSD.  I'm pretty happy with it so far. There are some posts on the mailing list from last year that explain one way to do it such as
> https://mail-index.netbsd.org/port-arm/2020/07/27/msg006904.html
> https://mail-index.netbsd.org/port-arm/2020/06/09/msg006740.html
> I documented the steps I took but as I am new to NetBSD there are no doubt things I misunderstand:
> http://ultralight.cc/posts/04d5f6c57b6f8e2b.html
> Chris

Home | Main Index | Thread Index | Old Index