Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD-HEAD amd64 refuses to build

    Date:        Wed, 18 Dec 2013 22:28:47 -0800 (PST)
    From:        "Thomas Mueller" <>
    Message-ID:  <>

  | I have e-mail set up for msmtp and mpop.

A PR is just an e-mail message with a particular body format, you can use
any mail program you like to send it - if you can't make the send-pr program
use the mailer that you have that works, then you can just use send-pr to
get the correct format, when you've done editing, save the file somewhere
you can remember its name (/tmp/PR or something) then use your mailer to
send that file (it goes to gnats-bugs%gnats.NetBSD.ORG@localhost)

  | I tried with postfix, but it failed to send allegedly because my hostname
  | was different from e-mail address: not a problem with msmtp.

I doubt that could be quite what it complained about, but I'm not a postfix
user (let alone admin) so I really have no idea.

But this is an example of what people have been saying (and I repeat
below) - there you described what happened, as you observed it, with
your interpretation.  Don't do that - include the actual message from
(in this case, postfix) and whatever config you did to it, what your
hostname is set to, what was in the headers of the e-mail you were
sending, ...  With all the info, others can duplicate your setup
(if they don't simply know what the problem or mis-config is) and
see if they can make it happen for them, which is the first step in
solving problems - it is really hard to work out what is going wrong when
you can't make it happen.

And put just one problem in one message, with a suitable subject header
(don't just reply to some other random message and jump into a new issue.)

  | I believe e-mail clients configure SMTP and POP3 servers independent of
  | system sendmail, and independent of hostname on the computer.

Yes, many do, I use nmh, and it can be configured to use anything as
the SMTP server.  Using something off the local system is always a bit
risky though, as those clients typically have no queue & retry mechanism,
so if the SMTP server you configured isn't available, or can't be reached,
then the mail just fails (sometimes even silently, depending upon the
client and how it is used).  A local MTA avoids that problem - it should
always be running and of course, is always reachable.

  | Would www interface work with lynx or links?  I built those from pkgsrc.

I have never tried, but I can't think of a reason why not - it is all just
text after all.   But there's no reason that you really have to send from
the system in question (it can be easier if you have output to show that
you want to attach) - anything that can connect to the web should allow you
to fill in the PR form there.

  | But some problems don't produce console output error messages,

Lots of problems don't - in fact, the vast majority don't.  When you were
asked for that, it wasn't that the "green text" was what was wanted,
necessarily - what people need to know is exactly what happened, as precisely
as possible, with as much information as possible (getting all the trivial
little details right if you possibly can - it can be a big difference if 
something reports a problem as 0x1c0000 compared to 0x1c000 ...)

What you shouldn't do (at least not without a lot of experience) is guess
at the problem cause, or attempt what you think should be a solution, and
then complain about that not working (you can try stuff if you want,  but
if you want help, describe the original problem as accurately as you can,
and don't be afraid of adding information, even if you suspect it might
be useless).

  | like the screenblank bug in NetBSD 5.x

The context for that one eludes me.

  | and getting dark screen after returning from X.

Unfortunately, quite a lot of the X drivers don't reset the graphics
to "dumb" mode perfectly when they quit - some are much worse than others.
Mostly people don't care all that much, as usually once X is running,
people just leave it running, and never exit (just shutdown or reboot).

So while the problem is a definite bug, and it would be nice to get it
fixed, it just isn't very high on anyone' priority list (it also typically
isn't a NetBSD problem - except in as much as NetBSD uses Xorg code).

  | Also, on NetBSD-current, when using more than one virtual terminal,
  | no more response to keyboard input, though most, but not all the time,
  | unplugging the  mouse brings back the keyboard.

I haven't seen that one myself, but I suspect that a recent fix to the
USB system (very recent fix) might just have done away with that (just
from what I read on the list and the symptoms reported, along with your
description).   So perhaps try a more up to date (like last day or two)
version of current...


Home | Main Index | Thread Index | Old Index