tech-x11 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Problems after xorg patch to 5.0_STABLE

On Sep 21, 2009, at 5:50 PM, Jukka Salmi wrote:

Rafal Boni --> port-i386 (2009-09-21 17:22:13 -0400):
On Mon, Sep 21, 2009 at 12:44:35PM -0700, Soren Jacobsen wrote:
On Sep 21, 2009, at 12:14 PM, Jukka Salmi wrote:

However, I removed the directory in question and extracted the set
again, but the screen still goes black as soon as Xorg is running.

Sadly, this is expected.  See PR xsrc/41870.  I am very tempted to
change our X server back to the old behavior of installing a default
cursor immediately and painting the background to that horrible
horrible eye-killing pattern. Much as I hate that default background,
black with no cursor is all kinds of wrong.

Yeah, too many people's reaction to the black screeen w/no cursor has
been "OMG, it's fuxored" (including mine, even now occasionally).  We
should go back to the damn grey stipled screen; it's not like it can't
be changed by whatever eye-candy is running on top of X as soon as it

I don't think that was the problem I was seeing.  Unless a side effect
is that you're not able to shut down the X server anymore... ;-)

With the 1.6.3 server, Ctrl+Alt+Backspace did not work, only sending a
SIGKILL to the server (by a user logged in over the network) worked, but
left the screen garbled until the system was restarted.  And blindly
typing `shutdown -r now' or pressing the power button to trigger a
shutdown by powerd(8) did not work as well.

In the meantime I've extracted the old sets to make Xorg (server 1.4.2)
is usable again...

There's a problem I'm having with -current; I wonder if it's related to the "can't exit" part of this.

For some reason, when I fire up recent versions of X, it doesn't seem to know the names of any keys. This means that assorted keyboard accelerators in my window manager (pkgsrc/wm/fvwm) don't work. xmodmap seems to fail to destroy any concept of the caps lock key's existence, I believe because I can't name it. If, though, I run xmodmap manually and do an fvwm Restart, all is happy at that level.

No, I don't know why. I'm getting ready to send-pr on this and a few other issues...

                --Steve Bellovin,

Home | Main Index | Thread Index | Old Index