tech-x11 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Problems after xorg patch to 5.0_STABLE

matthew green --> port-i386 (2009-09-22 04:23:14 +1000):
>    I just updated a netbsd-5 i386 system (ThinkPad X40) and I'm seeing the
>    problems you describe for the intel driver: black screen as soon as I
>    run startx(1), can't switch to another VT afterwards.  Logging in via
>    ssh and sending X a SIGKILL just leaves the display garbled.
> this is probably the xkbdata -> xkeyboard-config upgrade issue.
> we haven't yet implemented a real fix to help this upgrade as it
> involves deleting an old subdir before extracting xbase.tgz.  the
> simple workaround is to do this:
>       # rm -rf /usr/X11R7/lib/X11/xkb/symbols/pc
>       # pax -rzpe -f xbase.tgz ./usr/X11R7/lib/X11/xkb/symbols/pc

Uh, I forgot to mention that while extracting the sets I noticed the
following message from pax(1):

pax: Cannot rename ./usr/X11R7/lib/X11/xkb/symbols/pc.00265g to 
./usr/X11R7/lib/X11/xkb/symbols/pc (Is a directory)

However, I removed the directory in question and extracted the set
again, but the screen still goes black as soon as Xorg is running.

> you should be able to kill Xorg without SIGKILL, but SIGTERM, and
> it should shutdown and clean up the display properly.  did this not
> work?

No, only SIGKILL works.

>    And yes, xorgconfig indeed seems not to be included in the sets;
>    pcitweak, scanpci, in[blw], out[blw] and ioport are also missing.
> these utilities are no longer part of xorg-server.


Regards, Jukka

This email fills a much-needed gap in the archives.

Home | Main Index | Thread Index | Old Index