tech-toolchain archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Cross Building Native GCC

> Okay I am back :)
> I poked around the gcc inside the NetBSD source and yes .. the
> eco32--netbsd target seems broken.
> Building it outside the source-tree crashes while trying make
> all-target-libgcc.
> It doesn't find any headers :(
> I have a general idea of what is going wrong.
> Here the output for 'make all-target-libgcc' (same with all-target-libgomp)
> /home/okarin/temp/nbeg/./gcc/xgcc -B/home/okarin/temp/nbeg/./gcc/
> -B/home/okarin/eco32/tests/netbsd-new/usr/src/./obj/tooldir/eco32--netbsd/bin/
> -B/home/okarin/eco32/tests/netbsd-new/usr/src/./obj/tooldir/eco32--netbsd/lib/
> -isystem
> /home/okarin/eco32/tests/netbsd-new/usr/src/./obj/tooldir/eco32--netbsd/include
> -isystem
> /home/okarin/eco32/tests/netbsd-new/usr/src/./obj/tooldir/eco32--netbsd/sys-include   
> -Wwrite-strings -Wcast-qual -Wstrict-prototypes -Wmissing-prototypes
> -Wold-style-definition  -isystem ./include  -fPIC -g -DHAVE_GTHR_DEFAULT
> -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED -Dinhibit_libc  -I. -I.
> -I../.././gcc
> -I/home/okarin/eco32/tests/netbsd-new/usr/src/tools/gcc/../../external/gpl3/gcc/dist/libgcc
> -I/home/okarin/eco32/tests/netbsd-new/usr/src/tools/gcc/../../external/gpl3/gcc/dist/libgcc/.
> -I/home/okarin/eco32/tests/netbsd-new/usr/src/tools/gcc/../../external/gpl3/gcc/dist/libgcc/../gcc
> -I/home/okarin/eco32/tests/netbsd-new/usr/src/tools/gcc/../../external/gpl3/gcc/dist/libgcc/../include 
> -DHAVE_CC_TLS -DUSE_EMUTLS -o _muldi3.o -MT _muldi3.o -MD -MP -MF
> _muldi3.dep -DL_muldi3 -c
> /home/okarin/eco32/tests/netbsd-new/usr/src/tools/gcc/../../external/gpl3/gcc/dist/libgcc/../gcc/libgcc2.c
> \
> In file included from
> /home/okarin/eco32/tests/netbsd-new/usr/src/tools/gcc/../../external/gpl3/gcc/dist/libgcc/../gcc/libgcc2.c:29:0:
> /home/okarin/eco32/tests/netbsd-new/usr/src/tools/gcc/../../external/gpl3/gcc/dist/libgcc/../gcc/tsystem.h:44:20:
> fatal error: stddef.h: No such file or directory
> compilation terminated.
> Makefile:370: recipe for target '_muldi3.o' failed
> I will take care of this tomorrow.
My latest tests (given that I've done them correctly of course) revealed
that if I try to build all-target-libgomp from tools/gcc/obj/build with
make all-target-libgomp that it's missing some header - with it I mean
the gcc - it can't find header files it should be able to find in its
own sources.
My best guess atm is that my target is totally broken then again I
wonder .. who can it even build the kernel?

My idea (to shed some light on it) was to force the cross- compiler to
generate some omp-y stuff and see where it goes from there. I will check
my configuration once more and keep you posted.

I build the cross-compiler by hand by invoking nbmake-eco32 clean &&
nbmake-eco32 in tools/gcc/. That took care of building the
cross-compiler for me and I advanced into obj/build and tried make
all-target-libgomp - see the error above (it's the same error because
libgcc is needed for libgomp) Welcome to depencey hell :P


Home | Main Index | Thread Index | Old Index